On Wed, Jun 20, 2018 at 08:46:10AM +0800, Wanpeng Li wrote: > On Wed, 20 Jun 2018 at 08:07, Michael S. Tsirkin <mst@xxxxxxxxxx> wrote: > > > > On Tue, Jun 19, 2018 at 05:07:46PM -0500, Eric Blake wrote: > > > On 06/19/2018 10:17 AM, Paolo Bonzini wrote: > > > > On 16/06/2018 00:29, Michael S. Tsirkin wrote: > > > > > +static QemuOptsList qemu_dedicated_opts = { > > > > > + .name = "dedicated", > > > > > + .head = QTAILQ_HEAD_INITIALIZER(qemu_dedicated_opts.head), > > > > > + .desc = { > > > > > + { > > > > > + .name = "mem-lock", > > > > > + .type = QEMU_OPT_BOOL, > > > > > + }, > > > > > + { > > > > > + .name = "cpu-pm", > > > > > + .type = QEMU_OPT_BOOL, > > > > > + }, > > > > > + { /* end of list */ } > > > > > + }, > > > > > +}; > > > > > + > > > > > > > > Let the bikeshedding begin! > > > > > > > > 1) Should we deprecate -realtime? > > > > > > > > 2) Maybe -hostresource? > > > > > > What further things might we add in the future? > > > > > > -dedicated sounds wrong (it is an adjective, while most of our options are > > > nouns - thing -machine, -drive, -object, ...) > > > > > > -hostresource at least sounds like a noun, but is long to type. But at > > > least '-hostresource cpu-pm=on' reads reasonably well. > > > > Yes but host resource what? I feel it says nothing at all about what > > one can expect to find in this flag. > > > > > About the only other noun I could think of would be '-feature cpu-pm=on'. > > > > If we have nothing at all to say about what is grouping these things, > > we don't need a new flag. We can make it a machine property. > > > > It's user's hint that some host resource is dedicated to a VM. > > The commit 633711e82 (kvm: rename KVM_HINTS_DEDICATED to > KVM_HINTS_REALTIME) should be reverted according to several threads > discussion I think. > > Regards, > Wanpeng Li IMHO that is unrelated - these KVM hints are hints to *guest*. In this thread we are talking about hints to QEMU that are only necessary because QEMU is separate from the host scheduler/memory management. -- MST