On Tue, Jun 19, 2018 at 05:07:46PM -0500, Eric Blake wrote: > On 06/19/2018 10:17 AM, Paolo Bonzini wrote: > > On 16/06/2018 00:29, Michael S. Tsirkin wrote: > > > +static QemuOptsList qemu_dedicated_opts = { > > > + .name = "dedicated", > > > + .head = QTAILQ_HEAD_INITIALIZER(qemu_dedicated_opts.head), > > > + .desc = { > > > + { > > > + .name = "mem-lock", > > > + .type = QEMU_OPT_BOOL, > > > + }, > > > + { > > > + .name = "cpu-pm", > > > + .type = QEMU_OPT_BOOL, > > > + }, > > > + { /* end of list */ } > > > + }, > > > +}; > > > + > > > > Let the bikeshedding begin! > > > > 1) Should we deprecate -realtime? > > > > 2) Maybe -hostresource? > > What further things might we add in the future? > > -dedicated sounds wrong (it is an adjective, while most of our options are > nouns - thing -machine, -drive, -object, ...) > > -hostresource at least sounds like a noun, but is long to type. But at > least '-hostresource cpu-pm=on' reads reasonably well. Yes but host resource what? I feel it says nothing at all about what one can expect to find in this flag. > About the only other noun I could think of would be '-feature cpu-pm=on'. If we have nothing at all to say about what is grouping these things, we don't need a new flag. We can make it a machine property. It's user's hint that some host resource is dedicated to a VM. > -- > Eric Blake, Principal Software Engineer > Red Hat, Inc. +1-919-301-3266 > Virtualization: qemu.org | libvirt.org