On Tue, Jan 03, 2017 at 01:56:23PM +0100, David Hildenbrand wrote: > Am 16.12.2016 um 16:10 schrieb Radim Krčmář: > >irqchip_in_kernel() tried to save a bit by reusing pic_irqchip(), but it > >just complicated the code. > >Add a separate state for the irqchip mode. > > > >Signed-off-by: Radim Krčmář <rkrcmar@xxxxxxxxxx> > >--- > > v2: change two bools into one enum and rename everything [Paolo] > >--- > > arch/x86/include/asm/kvm_host.h | 8 +++++++- > > arch/x86/kvm/irq.h | 15 ++++++++------- > > arch/x86/kvm/x86.c | 5 +++-- > > 3 files changed, 18 insertions(+), 10 deletions(-) > > > >diff --git a/arch/x86/include/asm/kvm_host.h b/arch/x86/include/asm/kvm_host.h > >index 7892530cbacf..d3acd295446d 100644 > >--- a/arch/x86/include/asm/kvm_host.h > >+++ b/arch/x86/include/asm/kvm_host.h > >@@ -715,6 +715,12 @@ struct kvm_hv { > > HV_REFERENCE_TSC_PAGE tsc_ref; > > }; > > > >+enum kvm_irqchip_mode { > >+ KVM_IRQCHIP_NONE, > >+ KVM_IRQCHIP_KERNEL, /* created with KVM_CREATE_IRQCHIP */ > >+ KVM_IRQCHIP_SPLIT, /* created with KVM_CAP_SPLIT_IRQCHIP */ > > Was wondering if FULL/SPLIT would be a better naming. However I also > find irqchip_kernel() vs irqchip_in_kernel() slightly confusing. Me too. Since we have kvm_irqchip_mode enum above, how about renaming irqchip_{kernel|split}() into irqchip_mode_{kernel|split}()? Sorry for such a late comment... -- peterx -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html