Re: [PATCH 12/14] nvdimm acpi: rename nvdimm_dsm_reserved_root

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon,  7 Nov 2016 19:13:47 +0800
Xiao Guangrong <guangrong.xiao@xxxxxxxxxxxxxxx> wrote:

> Rename it to nvdimm_dsm_handle_reserved_root_method
> 
> Suggested-by: Igor Mammedov <imammedo@xxxxxxxxxx>
> Signed-off-by: Xiao Guangrong <guangrong.xiao@xxxxxxxxxxxxxxx>
Reviewed-by: Igor Mammedov <imammedo@xxxxxxxxxx>

> ---
>  hw/acpi/nvdimm.c | 7 ++++---
>  1 file changed, 4 insertions(+), 3 deletions(-)
> 
> diff --git a/hw/acpi/nvdimm.c b/hw/acpi/nvdimm.c
> index 6f6f51f..6692648 100644
> --- a/hw/acpi/nvdimm.c
> +++ b/hw/acpi/nvdimm.c
> @@ -571,8 +571,9 @@ exit:
>      g_free(read_fit_out);
>  }
>  
> -static void nvdimm_dsm_reserved_root(AcpiNVDIMMState *state, NvdimmDsmIn *in,
> -                                     hwaddr dsm_mem_addr)
> +static void
> +nvdimm_dsm_handle_reserved_root_method(AcpiNVDIMMState *state,
> +                                       NvdimmDsmIn *in, hwaddr dsm_mem_addr)
>  {
>      switch (in->function) {
>      case 0x0:
> @@ -842,7 +843,7 @@ nvdimm_dsm_write(void *opaque, hwaddr addr, uint64_t val, unsigned size)
>      }
>  
>      if (in->handle == NVDIMM_QEMU_RSVD_HANDLE_ROOT) {
> -        nvdimm_dsm_reserved_root(state, in, dsm_mem_addr);
> +        nvdimm_dsm_handle_reserved_root_method(state, in, dsm_mem_addr);
>          goto exit;
>      }
>  

--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]
  Powered by Linux