Ingo Molnar <mingo@xxxxxxxxxx> writes: >> @@ -3144,6 +3146,8 @@ static void vmclear_local_loaded_vmcss(void) >> static void kvm_cpu_vmxoff(void) >> { >> asm volatile (__ex(ASM_VMX_VMXOFF) : : : "cc"); >> + >> + intel_pt_vmx(0); >> } > > Yeah so the name intel_pt_vmx() is pretty information-free because it has no verb, > only nouns - please name new functions descriptively to after what they do! I do agree that it can use a better name (and this is a second attempt already). > Something like intel_pt_set_vmx_state() or so? Hmm how about intel_pt_handle_vmx()? Ideally, akin to the VMXON/VMXOFF insns, this could be two functions (intel_pt_handle_vmx{on,off}()) if the global namespace can take it. Regards, -- Alex -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html