On 10/11/2015 10:05, Takuya Yoshikawa wrote: > > >> BTW, on my todo list is to change the rmap items to a struct (with a >> single u64 inside) for type safety. Since you are touching this code, >> perhaps you can give it a shot? > > Yes, almost done here (assuming that you mean 'unsigned long'). Yes, thanks! > But I have some candidates for its name in mind: > > 1. struct kvm_rmap { unsigned long val; }; > 2. struct kvm_rmap_head { unsigned long val; }; > 3. struct kvm_rmap_list_head { unsigned long val; }; > 4. struct kvm_spte_list_head { unsigned long val; }; > > Since this is the head of the reverse mapping list of sptes, I thought > name 3 might be the best and first made a patch with it, but it was > a bit longer than I had hoped it to be. > > I have changed it to name 2, and it looks a bit nicer now, but even > shorter, e.g. name 1, may be good as well. > > Do you have any preference? I like kvm_rmap_head. Paolo -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html