On 2015/11/09 19:14, Paolo Bonzini wrote:
Can you also change kvm_mmu_mark_parents_unsync to use for_each_rmap_spte instead of pte_list_walk? It is the last use of pte_list_walk, and it's nice if we have two uses of for_each_rmap_spte with parent_ptes as the argument.
No problem, I will do. Since parent_ptes is also explained as the "reverse mapping" list of parent sptes (in mmu.txt and kvm_host.h), using rmap helpers will not look so strange.
BTW, on my todo list is to change the rmap items to a struct (with a single u64 inside) for type safety. Since you are touching this code, perhaps you can give it a shot?
Yes, almost done here (assuming that you mean 'unsigned long'). But I have some candidates for its name in mind: 1. struct kvm_rmap { unsigned long val; }; 2. struct kvm_rmap_head { unsigned long val; }; 3. struct kvm_rmap_list_head { unsigned long val; }; 4. struct kvm_spte_list_head { unsigned long val; }; Since this is the head of the reverse mapping list of sptes, I thought name 3 might be the best and first made a patch with it, but it was a bit longer than I had hoped it to be. I have changed it to name 2, and it looks a bit nicer now, but even shorter, e.g. name 1, may be good as well. Do you have any preference? Takuya -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html