The version is Okay to me. Thanks for your work!:) Avi, Please help to applied it, Thanks! Acked-by : Xiantao Zhang <xiantao.zhang@xxxxxxxxx> -----Original Message----- From: Jes Sorensen [mailto:jes@xxxxxxx] Sent: Wednesday, January 21, 2009 10:17 PM To: Zhang, Xiantao Cc: kvm-ia64@xxxxxxxxxxxxxxx Subject: Re: [patch] dynamic nr online cpus Hi Xiantao, Here's an update version of the online_vcpus patch. I agree with you that the name online_vcpus is more appropriate and I used your trick to get to struct kvm, so it's a lot cleaner than the old version. I renamed VM_BASE to KVM_VM_BASE as it seems a more correct name to me and has less chance of clashing with something. In addition the parenthesis I added are required to avoid unexpected results from CPP when you typecast it to struct kvm *. Cheers, Jes Zhang, Xiantao wrote: > Hi, Jes > This patch is okay to me, and still have some minor comments below, and expect them to address in your final patch. Thanks! > > 1. For readability, I prefer to use online_vcpus intead of online_cpus > 2. I don't think it is necessary to save a copy in vcpu's private data, just use the following code to get the kvm pointer and access its non-pointer fileds in vmm module, > struct kvm *get_kvm() { > return (struct kvm*) VM_BASE; > } > > After getting kvm pointer, you can use it for vcpu.c's change. > Xiantao > > Jes Sorensen wrote: >> Hi, >> >> Working on allowing larger max vcpus I'd like to put in this patch >> that calculates the number of online cpus. It's a building block for >> allowing the larger number of max vcpus without crippling performance >> for the smaller cases. >> >> Cheers, >> Jes -- To unsubscribe from this list: send the line "unsubscribe kvm-ia64" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html