On Tue, Sep 20, 2022, Ricardo Koller wrote: > On Tue, Sep 20, 2022 at 06:07:13PM +0000, Sean Christopherson wrote: > > On Tue, Sep 20, 2022, Ricardo Koller wrote: > > > The previous commit added support for callers of ____vm_create() to specify > > > > Changelog is stale, ____vm_create() no longer takes the struct. > > > > Side topic, it's usually a good idea to use "strong" terminology when referencing > > past/future changes, e.g. if patches get shuffled around for whatever reason, > > then "previous commit" may become stale/misleading. > > > > It's fairly easy to convey the same info ("something happened recently" or > > "something is going to happen soon") without being so explicit, e.g. > > > > Wire up common code to use the appropriate code, page table, and data > > memmslots that were recently added instead of hardcoding '0' for the > > memslot. > > > > or > > > > Now that kvm_vm allows specifying different memslots for code, page > > tables, and data, use the appropriate memslot when making allocations > > in common/libraty code. > > > > > what memslots to use for code, page-tables, and data allocations. Change > > > them accordingly: > > > > > > - stacks, code, and exception tables use the code memslot > > > > Huh? Stacks and exceptions are very much data, not code. > > > > I would *really* like to have the data region only store test data. It > makes things easier for the test implementation, like owning the whole > region. That's fine, but allocating stack as "code" is super confusing. > At the same I wanted to have a single region for all the "core pages" like > code, descriptors, exception tables, stacks, etc. Not sure what to call it > though. Why? Code is very different than all those other things. E.g. the main reason KVM doesn't provide "not-executable" or "execute-only" memslots is because there's never been a compelling use case, not because it's difficult to implement. If KVM were to ever add such functionality, then we'd want/need selftests to have a dedicated code memslot. > So, what about one of these 2 options: > > Option A: 3 regions, where we call the "code" region something else, like > "core". > Option B: 4 regions: code, page-tables, core-data (stacks, exception tables, etc), > test-data. I like (B), though I'd just call 'em "DATA" and "TEST_DATA". IIUC, TEST_DATA is the one you want to be special, i.e. it's ok if something that's not "core" allocates in DATA, but it's not ok if "core" allocates in TEST_DATA. That yields an easy to understand "never use TEST_DATA" rule for library/common/core functionality, with the code vs. page tables vs. data decision (hopefully) being fairly obvious. Defining CORE_DATA will force developers to make judgement calls and probably lead to bikeshedding over whether something is considered "core" code. _______________________________________________ kvmarm mailing list kvmarm@xxxxxxxxxxxxxxxxxxxxx https://lists.cs.columbia.edu/mailman/listinfo/kvmarm