Re: [PATCH v7 2/5] arm64: KVM: encapsulate kvm_cpu_context in kvm_host_data

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, Dec 11, 2018 at 01:29:51PM +0100, Christoffer Dall wrote:
> On Tue, Dec 11, 2018 at 12:13:37PM +0000, Andrew Murray wrote:
> > The virt/arm core allocates a percpu structure as per the kvm_cpu_context_t
> > type, at present this is typedef'd to kvm_cpu_context and used to store
> > host cpu context. The kvm_cpu_context structure is also used elsewhere to
> > hold vcpu context. In order to use the percpu to hold additional future
> > host information we encapsulate kvm_cpu_context in a new structure.
> > 
> > Signed-off-by: Andrew Murray <andrew.murray@xxxxxxx>
> > ---
> >  arch/arm64/include/asm/kvm_host.h | 8 ++++++--
> >  arch/arm64/kernel/asm-offsets.c   | 3 ++-
> >  virt/kvm/arm/arm.c                | 4 +++-
> >  3 files changed, 11 insertions(+), 4 deletions(-)
> > 
> > diff --git a/arch/arm64/include/asm/kvm_host.h b/arch/arm64/include/asm/kvm_host.h
> > index 1550192..bcf9d60 100644
> > --- a/arch/arm64/include/asm/kvm_host.h
> > +++ b/arch/arm64/include/asm/kvm_host.h
> > @@ -205,7 +205,11 @@ struct kvm_cpu_context {
> >  	struct kvm_vcpu *__hyp_running_vcpu;
> >  };
> >  
> > -typedef struct kvm_cpu_context kvm_cpu_context_t;
> > +struct kvm_host_data {
> > +	struct kvm_cpu_context __kvm_cpu_state;
> > +};
> > +
> > +typedef struct kvm_host_data kvm_cpu_context_t;
> 
> Now I'm confused based on the conversation on the last version.
> 
> I think it's bizarre to use the typedef to rename things in this way.
> 
> Can you please make this:
> 
>    struct kvm_cpu_context;
>    typedef struct kvm_cpu_context kvm_cpu_context_t;
> 
>    struct kvm_host_data;
>    typedef struct kvm_host_data kvm_host_data_t;
> 
> And change the code with the fallout from that.

I guess I was trying to avoid similar naming issues on arm32. If we
make the above changes (and thus the DEFINE_PER_CPU in virt/kvm/arm/arm.c)
then we need to change arm (arch/arm/include/asm/kvm_host.h) such that:

typedef struct kvm_cpu_context kvm_cpu_context_t;

becomes:

typedef struct kvm_cpu_context kvm_host_data_t;

though I guess this may be acceptable?


On a similar note the hunk in my last email on the previous thread
would cause a breakage on arm32:

@@ -374,7 +376,7 @@ void kvm_arch_vcpu_load(struct kvm_vcpu *vcpu, int cpu)
        }
 
        vcpu->cpu = cpu;
-       vcpu->arch.host_cpu_context = this_cpu_ptr(&kvm_host_cpu_state);
+       vcpu->arch.host_cpu_context = &cpu_ctxt->__kvm_cpu_state;
 
        kvm_arm_set_running_vcpu(vcpu);
        kvm_vgic_load(vcpu);

.. instead of this hunk I'll update the uses of host_cpu_context in the
arm64 code.

Thanks,

Andrew Murray


> 
> 
> >  
> >  struct kvm_vcpu_arch {
> >  	struct kvm_cpu_context ctxt;
> > @@ -241,7 +245,7 @@ struct kvm_vcpu_arch {
> >  	struct kvm_guest_debug_arch external_debug_state;
> >  
> >  	/* Pointer to host CPU context */
> > -	kvm_cpu_context_t *host_cpu_context;
> > +	struct kvm_cpu_context *host_cpu_context;
> >  
> >  	struct thread_info *host_thread_info;	/* hyp VA */
> >  	struct user_fpsimd_state *host_fpsimd_state;	/* hyp VA */
> > diff --git a/arch/arm64/kernel/asm-offsets.c b/arch/arm64/kernel/asm-offsets.c
> > index 323aeb5..da34022 100644
> > --- a/arch/arm64/kernel/asm-offsets.c
> > +++ b/arch/arm64/kernel/asm-offsets.c
> > @@ -142,7 +142,8 @@ int main(void)
> >    DEFINE(CPU_FP_REGS,		offsetof(struct kvm_regs, fp_regs));
> >    DEFINE(VCPU_FPEXC32_EL2,	offsetof(struct kvm_vcpu, arch.ctxt.sys_regs[FPEXC32_EL2]));
> >    DEFINE(VCPU_HOST_CONTEXT,	offsetof(struct kvm_vcpu, arch.host_cpu_context));
> > -  DEFINE(HOST_CONTEXT_VCPU,	offsetof(struct kvm_cpu_context, __hyp_running_vcpu));
> > +  DEFINE(HOST_CONTEXT_VCPU,	offsetof(struct kvm_cpu_context, __hyp_running_vcpu)
> > +				+ offsetof(struct kvm_host_data, __kvm_cpu_state));
> 
> This should be HOST_DATA_VCPU, then.
> 
> 
> Thanks,
> 
>     Christoffer
> 
> >  #endif
> >  #ifdef CONFIG_CPU_PM
> >    DEFINE(CPU_SUSPEND_SZ,	sizeof(struct cpu_suspend_ctx));
> > diff --git a/virt/kvm/arm/arm.c b/virt/kvm/arm/arm.c
> > index 150c8a6..4f2e534 100644
> > --- a/virt/kvm/arm/arm.c
> > +++ b/virt/kvm/arm/arm.c
> > @@ -361,8 +361,10 @@ int kvm_arch_vcpu_init(struct kvm_vcpu *vcpu)
> >  void kvm_arch_vcpu_load(struct kvm_vcpu *vcpu, int cpu)
> >  {
> >  	int *last_ran;
> > +	kvm_cpu_context_t *cpu_ctxt;
> >  
> >  	last_ran = this_cpu_ptr(vcpu->kvm->arch.last_vcpu_ran);
> > +	cpu_ctxt = this_cpu_ptr(&kvm_host_cpu_state);
> >  
> >  	/*
> >  	 * We might get preempted before the vCPU actually runs, but
> > @@ -374,7 +376,7 @@ void kvm_arch_vcpu_load(struct kvm_vcpu *vcpu, int cpu)
> >  	}
> >  
> >  	vcpu->cpu = cpu;
> > -	vcpu->arch.host_cpu_context = this_cpu_ptr(&kvm_host_cpu_state);
> > +	vcpu->arch.host_cpu_context = &cpu_ctxt->__kvm_cpu_state;
> >  
> >  	kvm_arm_set_running_vcpu(vcpu);
> >  	kvm_vgic_load(vcpu);
> > -- 
> > 2.7.4
> > 
_______________________________________________
kvmarm mailing list
kvmarm@xxxxxxxxxxxxxxxxxxxxx
https://lists.cs.columbia.edu/mailman/listinfo/kvmarm



[Index of Archives]     [Linux KVM]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux