On Fri, Nov 1, 2024 at 2:16 PM Pavel Begunkov <asml.silence@xxxxxxxxx> wrote: > > On 11/1/24 20:11, Mina Almasry wrote: > > On Tue, Oct 29, 2024 at 4:06 PM David Wei <dw@xxxxxxxxxxx> wrote: > >> > > ... > >> +static void io_zcrx_get_buf_uref(struct net_iov *niov) > >> +{ > >> + atomic_long_add(IO_ZC_RX_UREF, &niov->pp_ref_count); > >> +} > >> + > > > > This is not specific to io_rcrx I think. Please rename this and put it > > somewhere generic, like netmem.h. > > > > Then tcp_recvmsg_dmabuf can use the same helper instead of the very > > ugly call it currently does: > > > > - atomic_long_inc(&niov->pp_ref_count); > > + net_iov_pp_ref_get(niov, 1); > > > > Or something. > > > > In general I think io_uring code can do whatever it wants with the > > io_uring specific bits in net_iov (everything under net_area_owner I > > think), but please lets try to keep any code touching the generic > > net_iov fields (pp_pagic, pp_ref_count, and others) in generic > > helpers. > > I'm getting confused, io_uring shouldn't be touching these > fields, but on the other hand should export net/ private > netmem_priv.h and page_pool_priv.h and directly hard code a bunch > of low level setup io_uring that is currently in page_pool.c > The only thing requested from this patch is to turn io_zcrx_get_buf_uref into something more generic. I'm guessing your confusion is following my other comments in "[PATCH v7 06/15] net: page pool: add helper creating area from pages". Let me take a closer look at my feedback there. -- Thanks, Mina