On Tue, Oct 29, 2024 at 4:06 PM David Wei <dw@xxxxxxxxxxx> wrote: > ... > +static void io_zcrx_get_buf_uref(struct net_iov *niov) > +{ > + atomic_long_add(IO_ZC_RX_UREF, &niov->pp_ref_count); > +} > + This is not specific to io_rcrx I think. Please rename this and put it somewhere generic, like netmem.h. Then tcp_recvmsg_dmabuf can use the same helper instead of the very ugly call it currently does: - atomic_long_inc(&niov->pp_ref_count); + net_iov_pp_ref_get(niov, 1); Or something. In general I think io_uring code can do whatever it wants with the io_uring specific bits in net_iov (everything under net_area_owner I think), but please lets try to keep any code touching the generic net_iov fields (pp_pagic, pp_ref_count, and others) in generic helpers. -- Thanks, Mina