On Tue, Sep 02, 2014 at 01:04:34PM +0200, Daniel Vetter wrote: > On Tue, Sep 02, 2014 at 10:59:06AM +0100, Damien Lespiau wrote: > > On Tue, Sep 02, 2014 at 10:18:20AM +0100, Arun Siluvery wrote: > > > - igt_assert(fd >= 0); > > > + if (fd < 0) > > > + igt_skip_on("No Workaround table available !!\n"); > > > > That's not quite a correct use of the API. The _on is there to signal > > the first argument is an expression. This will work only because the > > string is evaluated to true. You probably want to use igt_skip_on_f() > > > > http://people.freedesktop.org/~danvet/igt/intel-gpu-tools-i-g-t-core.html#igt-skip-on-f > > Or just igt_skip_on - we dump the expression that was tested, which should > be fairly informational. At least when fd would have a better name ;-) Use igt_require(), it produces more natural phrasing in usage and output. -Chris -- Chris Wilson, Intel Open Source Technology Centre _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/intel-gfx