This is v3 of [1] with the following changes: - Rename intel_hpd_suspend/resume() to intel_hpd_block/unblock(). (Jani, patch 2,3,5) - Handle encoders using a shared HPD pin properly, during blocking/unblocking the HPD handling. (patch 2, 5) [1] https://lore.kernel.org/all/20250224193115.2058512-1-imre.deak@xxxxxxxxx Cc: Jani Nikula <jani.nikula@xxxxxxxxx> Imre Deak (5): drm/i915/hpd: Let an HPD pin be in the disabled state when handling missed IRQs drm/i915/hpd: Add support for blocking the IRQ handling on an HPD pin drm/i915/dp: Fix link training interrupted by a short HPD pulse drm/i915/dp: Queue a link check after link training is complete drm/i915/crt: Use intel_hpd_block/unblock() instead of intel_hpd_disable/enable() drivers/gpu/drm/i915/display/intel_crt.c | 7 +- .../gpu/drm/i915/display/intel_display_core.h | 1 + .../drm/i915/display/intel_dp_link_training.c | 23 +- drivers/gpu/drm/i915/display/intel_hotplug.c | 291 ++++++++++++++---- drivers/gpu/drm/i915/display/intel_hotplug.h | 5 +- 5 files changed, 263 insertions(+), 64 deletions(-) -- 2.44.2