> -----Original Message----- > From: Jani Nikula <jani.nikula@xxxxxxxxxxxxxxx> > Sent: Tuesday, 26 November 2024 11.30 > To: Kahola, Mika <mika.kahola@xxxxxxxxx>; intel-gfx@xxxxxxxxxxxxxxxxxxxxx > Cc: Sousa, Gustavo <gustavo.sousa@xxxxxxxxx>; Jadav, Raag > <raag.jadav@xxxxxxxxx>; Kahola, Mika <mika.kahola@xxxxxxxxx> > Subject: Re: [PATCH v5 1/2] drm/i915/xe3lpd: Power request > asserting/deasserting > > On Tue, 05 Nov 2024, Mika Kahola <mika.kahola@xxxxxxxxx> wrote: > > There is a HW issue that arises when there are race conditions between > > TCSS entering/exiting TC7 or TC10 states while the driver is > > asserting/deasserting TCSS power request. As a workaround, Display > > driver will implement a mailbox sequence to ensure that the TCSS is in > > TC0 when TCSS power request is asserted/deasserted. > > > > The sequence is the following > > > > 1. Read mailbox command status and wait until run/busy bit is > > clear > > 2. Write mailbox data value '1' for power request asserting > > and '0' for power request deasserting 3. Write mailbox command > > run/busy bit and command value with 0x1 4. Read mailbox command and > > wait until run/busy bit is clear > > before continuing power request. > > > > v2: Rename WA function (Gustavo) > > Limit WA only for PTL platform with a TODO note (Gustavo) > > Add TCSS_DISP_MAILBOX_IN_CMD_RUN_BUSY for clarity when writing > > register data (Gustavo) > > Move register defs from i915_reg.h to intel_cx0_phy_regs.h > > (Gustavo) > > v3: Use "struct intel_display" instead of "struct drm_i915_private" (Jani) > > Move defs above C10 definitions in the > > intel_cx0_phy_regs.h file (Gustavo) > > Move drm_WARN_ON() inside WA function (Gustavo) > > Rename workaround function as wa_14020908590() (Gustvo) > > Use boolean enable instead of if-else structure (Raag) > > v4: Drop drm_WARN_ON() (Raag) > > Fix function definition to fit into a single line (Raag) > > > > Reviewed-by: Raag Jadav <raag.jadav@xxxxxxxxx> > > Signed-off-by: Mika Kahola <mika.kahola@xxxxxxxxx> > > --- > > .../gpu/drm/i915/display/intel_cx0_phy_regs.h | 8 +++++ > > drivers/gpu/drm/i915/display/intel_tc.c | 31 +++++++++++++++++++ > > 2 files changed, 39 insertions(+) > > > > diff --git a/drivers/gpu/drm/i915/display/intel_cx0_phy_regs.h > > b/drivers/gpu/drm/i915/display/intel_cx0_phy_regs.h > > index f0e5c196eae4..5a0b55cca4a3 100644 > > --- a/drivers/gpu/drm/i915/display/intel_cx0_phy_regs.h > > +++ b/drivers/gpu/drm/i915/display/intel_cx0_phy_regs.h > > @@ -200,6 +200,14 @@ > > #define XELPDP_SSC_ENABLE_PLLA REG_BIT(1) > > #define XELPDP_SSC_ENABLE_PLLB REG_BIT(0) > > > > +#define TCSS_DISP_MAILBOX_IN_CMD _MMIO(0x161300) > > +#define TCSS_DISP_MAILBOX_IN_CMD_RUN_BUSY REG_BIT(31) > > +#define TCSS_DISP_MAILBOX_IN_CMD_CMD_MASK REG_GENMASK(7, 0) > > +#define TCSS_DISP_MAILBOX_IN_CMD_DATA(val) > (TCSS_DISP_MAILBOX_IN_CMD_RUN_BUSY | \ > > Why does this contain TCSS_DISP_MAILBOX_IN_CMD_RUN_BUSY? You set it > separately anyway (and that's how it should be). This is a leftover. The suggestion was to use these separately and not combine these. Simply forgot to remove this from here. > > > + > REG_FIELD_PREP(TCSS_DISP_MAILBOX_IN_CMD_CMD_MASK, val)) > > + > > +#define TCSS_DISP_MAILBOX_IN_DATA _MMIO(0x161304) > > + > > /* C10 Vendor Registers */ > > #define PHY_C10_VDR_PLL(idx) (0xC00 + (idx)) > > #define C10_PLL0_FRACEN REG_BIT8(4) > > diff --git a/drivers/gpu/drm/i915/display/intel_tc.c > > b/drivers/gpu/drm/i915/display/intel_tc.c > > index b16c4d2d4077..e40d55f4c0c4 100644 > > --- a/drivers/gpu/drm/i915/display/intel_tc.c > > +++ b/drivers/gpu/drm/i915/display/intel_tc.c > > @@ -1013,6 +1013,30 @@ xelpdp_tc_phy_wait_for_tcss_power(struct > intel_tc_port *tc, bool enabled) > > return true; > > } > > > > +static void wa_14020908590(struct intel_display *display, bool > > +enable) > > Yeah I still don't like functions named wa_14020908590. It's meaningless. What > does it do? That's a good point. We do have few functions in our driver that have workaround number in its name. What would be the better way? Add a comment that references to workaround number and have a meaningful function name? > > > +{ > > + /* check if mailbox is running busy */ > > + if (intel_de_wait_for_clear(display, TCSS_DISP_MAILBOX_IN_CMD, > > + TCSS_DISP_MAILBOX_IN_CMD_RUN_BUSY, > 10)) { > > + drm_dbg_kms(display->drm, > > + "Timeout waiting for TCSS mailbox run/busy bit to > clear\n"); > > + return; > > + } > > + > > + intel_de_write(display, TCSS_DISP_MAILBOX_IN_DATA, enable); > > Not a fan of bool -> u32 implicit conversion here, with the register contents not > described. Ok. I will modify this to use u32 instead. > > > + intel_de_write(display, TCSS_DISP_MAILBOX_IN_CMD, > > + TCSS_DISP_MAILBOX_IN_CMD_RUN_BUSY | > > + TCSS_DISP_MAILBOX_IN_CMD_DATA(0x1)); > > + > > + /* wait to clear mailbox running busy bit before continuing */ > > + if (intel_de_wait_for_clear(display, TCSS_DISP_MAILBOX_IN_CMD, > > + TCSS_DISP_MAILBOX_IN_CMD_RUN_BUSY, > 10)) { > > + drm_dbg_kms(display->drm, > > + "Timeout after writing data to mailbox. Mailbox > run/busy bit did not clear\n"); > > + return; > > + } > > +} > > + > > static void __xelpdp_tc_phy_enable_tcss_power(struct intel_tc_port > > *tc, bool enable) { > > struct drm_i915_private *i915 = tc_to_i915(tc); @@ -1022,6 +1046,13 > > @@ static void __xelpdp_tc_phy_enable_tcss_power(struct intel_tc_port > > *tc, bool ena > > > > assert_tc_cold_blocked(tc); > > > > + /* > > + * Gfx driver WA 14020908590 for PTL tcss_rxdetect_clkswb_req/ack > > + * handshake violation when pwwreq= 0->1 during TC7/10 entry > > + */ > > + if (DISPLAY_VER(i915) == 30) > > + wa_14020908590(&i915->display, enable); > > You should add > > struct intel_display *display = &i915->display; > > local variable already in this patch, so the next patch doesn't have to modify the > above line again. You can do the subsequent conversions in the follow-up. Ok. I will make this change Thanks for the review! -Mika- > > BR, > Jani. > > > > + > > val = intel_de_read(i915, reg); > > if (enable) > > val |= XELPDP_TCSS_POWER_REQUEST; > > -- > Jani Nikula, Intel