On Wed, 16 Oct 2024, Ville Syrjala <ville.syrjala@xxxxxxxxxxxxxxx> wrote: > diff --git a/drivers/gpu/drm/i915/display/intel_pfit.h b/drivers/gpu/drm/i915/display/intel_pfit.h > new file mode 100644 > index 000000000000..add8d78de2c9 > --- /dev/null > +++ b/drivers/gpu/drm/i915/display/intel_pfit.h > @@ -0,0 +1,15 @@ > +/* SPDX-License-Identifier: MIT */ > +/* > + * Copyright © 2024 Intel Corporation > + */ > + > +#ifndef __INTEL_PFIT_H__ > +#define __INTEL_PFIT_H__ > + > +struct drm_connector_state; > +struct intel_crtc_state; > + > +int intel_panel_fitting(struct intel_crtc_state *crtc_state, > + const struct drm_connector_state *conn_state); Nitpick, would be nice to rename this to intel_pfit_something() in follow-up. Reviewed-by: Jani Nikula <jani.nikula@xxxxxxxxx> -- Jani Nikula, Intel