On Tue, Oct 15, 2024 at 03:56:10PM +0530, Riana Tauro wrote: > Hi Raag > > On 10/11/2024 4:02 PM, Raag Jadav wrote: > > Having similar naming convention in intel-family.h and intel_device_info.h > > results in redefinition of a few platforms. Define CPU IDs in its own file > > to avoid this. > > > > Signed-off-by: Raag Jadav <raag.jadav@xxxxxxxxx> > > --- > > drivers/gpu/drm/i915/Makefile | 1 + > > drivers/gpu/drm/i915/gt/intel_wa_cpu.c | 34 +++++++++++++++++++++ > > drivers/gpu/drm/i915/gt/intel_workarounds.h | 2 ++ > > 3 files changed, 37 insertions(+) > > create mode 100644 drivers/gpu/drm/i915/gt/intel_wa_cpu.c > > > > diff --git a/drivers/gpu/drm/i915/Makefile b/drivers/gpu/drm/i915/Makefile > > index c63fa2133ccb..1f9b503ab976 100644 > > --- a/drivers/gpu/drm/i915/Makefile > > +++ b/drivers/gpu/drm/i915/Makefile > > @@ -121,6 +121,7 @@ gt-y += \ > > gt/intel_timeline.o \ > > gt/intel_tlb.o \ > > gt/intel_wopcm.o \ > > + gt/intel_wa_cpu.o \ > Why is this file under gt/ ? Doesn't seem to be gt specific The idea is to couple it with intel_workarounds.c Any other place it'd rather be? > > gt/intel_workarounds.o \ > > gt/shmem_utils.o \ > > gt/sysfs_engines.o Raag