Re: [PATCH 10/16] drm/i915/display: Refactor enable_joiner_pipes

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, Sep 23, 2024 at 11:43:30PM +0530, Ankit Nautiyal wrote:
> Pass the current pipe into enabled_joiner_pipes(), and let it figure out
> the proper bitmasks for us.
> 
> v2:
> -Simplify helper get_joiner_primary_pipes. (Ville)
> -Nuke get_joiner_secondary_pipes. (Ville)
> -Add more drm_WARNs and checks for final primary/secondary pipes.
> (Ville)
> 
> Signed-off-by: Ankit Nautiyal <ankit.k.nautiyal@xxxxxxxxx>
> Suggested-by: Ville Syrjälä <ville.syrjala@xxxxxxxxxxxxxxx>
> ---
>  drivers/gpu/drm/i915/display/intel_display.c | 85 +++++++++++---------
>  1 file changed, 48 insertions(+), 37 deletions(-)
> 
> diff --git a/drivers/gpu/drm/i915/display/intel_display.c b/drivers/gpu/drm/i915/display/intel_display.c
> index c42ba377d247..f35d1e1fdb8a 100644
> --- a/drivers/gpu/drm/i915/display/intel_display.c
> +++ b/drivers/gpu/drm/i915/display/intel_display.c
> @@ -3706,7 +3706,14 @@ static void enabled_ultrajoiner_pipes(struct drm_i915_private *i915,
>  	}
>  }
>  
> -static void enabled_joiner_pipes(struct drm_i915_private *dev_priv,
> +static u8 get_joiner_primary_pipe(enum pipe pipe, u8 primary_pipes)
> +{
> +	primary_pipes &= GENMASK(pipe, 0);
> +
> +	return primary_pipes ? BIT(fls(primary_pipes) - 1) : 0;
> +}
> +
> +static void enabled_joiner_pipes(struct drm_i915_private *dev_priv, enum pipe pipe,
>  				 u8 *primary_pipes, u8 *secondary_pipes)
>  {
>  	struct intel_display *display = to_intel_display(&dev_priv->drm);
> @@ -3774,41 +3781,47 @@ static void enabled_joiner_pipes(struct drm_i915_private *dev_priv,
>  		 expected_ultrajoiner_secondary_pipes(primary_ultrajoiner_pipes),
>  		 secondary_ultrajoiner_pipes);
>  
> -	*primary_pipes = primary_uncompressed_joiner_pipes | primary_bigjoiner_pipes |
> -			 primary_ultrajoiner_pipes;
> -	*secondary_pipes = secondary_uncompressed_joiner_pipes | secondary_bigjoiner_pipes |
> -			 secondary_ultrajoiner_pipes;
> -}
> -
> -static enum pipe get_joiner_primary_pipe(enum pipe pipe, u8 primary_pipes, u8 secondary_pipes)
> -{
> -	if ((secondary_pipes & BIT(pipe)) == 0)
> -		return pipe;
> -
> -	/* ignore everything above our pipe */
> -	primary_pipes &= ~GENMASK(7, pipe);
> -
> -	/* highest remaining bit should be our primary pipe */
> -	return fls(primary_pipes) - 1;
> -}
> +	*primary_pipes = 0;
> +	*secondary_pipes = 0;
>  
> -static u8 get_joiner_secondary_pipes(enum pipe pipe, u8 primary_pipes, u8 secondary_pipes)
> -{
> -	enum pipe primary_pipe, next_primary_pipe;
> +	if (ultrajoiner_pipes & BIT(pipe)) {
> +		*primary_pipes = get_joiner_primary_pipe(pipe, primary_ultrajoiner_pipes);
> +		*secondary_pipes = secondary_ultrajoiner_pipes &
> +				   expected_ultrajoiner_secondary_pipes(primary_ultrajoiner_pipes);
                                                                        ^^^^^^^^^^^^^^^^^^^^^^^^^
That should be '*primary_pipes'.

This branch is missing the final WARN_ON you have in the
bigjoiner uncompressed joiner branches below.

> +		return;
> +	}
>  
> -	primary_pipe = get_joiner_primary_pipe(pipe, primary_pipes, secondary_pipes);
> +	if (uncompressed_joiner_pipes & BIT(pipe)) {
> +		*primary_pipes = get_joiner_primary_pipe(pipe, primary_uncompressed_joiner_pipes);
> +		*secondary_pipes =
> +			secondary_uncompressed_joiner_pipes &
> +			expected_uncompressed_joiner_secondary_pipes(primary_uncompressed_joiner_pipes);
> +	} else if (bigjoiner_pipes & BIT(pipe)) {
> +		*primary_pipes = get_joiner_primary_pipe(pipe, primary_bigjoiner_pipes);
> +		*secondary_pipes = secondary_bigjoiner_pipes &
> +				   expected_bigjoiner_secondary_pipes(primary_bigjoiner_pipes);

Same '*primary_pipes' thing in these two.

> +	}

I would probably get rid of the if-else construct here, and just
handle each joiner type completely independently, just like ultrajoiner
above. Makes the code more regular and thus easier to reason about.

>  
> -	if ((primary_pipes & BIT(primary_pipe)) == 0)
> -		return 0;
> +	drm_WARN(display->drm,
> +		 expected_bigjoiner_secondary_pipes(*primary_pipes) != *secondary_pipes,
> +		 "Wrong bigjoiner secondary pipes for primary_pipes %#x (expected %#x, current %#x for)\n",
> +		 *primary_pipes,
> +		 expected_bigjoiner_secondary_pipes(*primary_pipes),
> +		 *secondary_pipes);
>  
> -	/* ignore our primary pipe and everything below it */
> -	primary_pipes &= ~GENMASK(primary_pipe, 0);
> -	/* make sure a high bit is set for the ffs() */
> -	primary_pipes |= BIT(7);
> -	/* lowest remaining bit should be the next primary pipe */
> -	next_primary_pipe = ffs(primary_pipes) - 1;
> +	drm_WARN(display->drm,
> +		 expected_uncompressed_joiner_secondary_pipes(*primary_pipes) != *secondary_pipes,
> +		 "Wrong uncompressed joiner secondary pipes for primary_pipes %#x (expected %#x, current %#x for)\n",
> +		 *primary_pipes,
> +		 expected_uncompressed_joiner_secondary_pipes(*primary_pipes),
> +		 *secondary_pipes);
>  
> -	return secondary_pipes & GENMASK(next_primary_pipe - 1, primary_pipe);
> +	drm_WARN(display->drm,
> +		 expected_ultrajoiner_secondary_pipes(*primary_pipes) != *secondary_pipes,
> +		 "Wrong ultrajoiner secondary pipes for primary_pipes %#x (expected %#x, current %#x for)\n",
> +		 *primary_pipes,
> +		 expected_ultrajoiner_secondary_pipes(*primary_pipes),
> +		 *secondary_pipes);

I'm not quite sure what's happening here. We already bailed out for
ultrajoiner earlier.

The patch is pretty hard to read. Did you try --patience vs. not when
generating it in case one or the other makes for a more readalbe end
result?

>  }
>  
>  static u8 hsw_panel_transcoders(struct drm_i915_private *i915)
> @@ -3880,10 +3893,10 @@ static u8 hsw_enabled_transcoders(struct intel_crtc *crtc)
>  		enabled_transcoders |= BIT(cpu_transcoder);
>  
>  	/* joiner secondary -> consider the primary pipe's transcoder as well */
> -	enabled_joiner_pipes(dev_priv, &primary_pipes, &secondary_pipes);
> +	enabled_joiner_pipes(dev_priv, crtc->pipe, &primary_pipes, &secondary_pipes);
>  	if (secondary_pipes & BIT(crtc->pipe)) {
>  		cpu_transcoder = (enum transcoder)
> -			get_joiner_primary_pipe(crtc->pipe, primary_pipes, secondary_pipes);
> +			ffs(get_joiner_primary_pipe(crtc->pipe, primary_pipes)) - 1;
>  		if (transcoder_ddi_func_is_enabled(dev_priv, cpu_transcoder))
>  			enabled_transcoders |= BIT(cpu_transcoder);
>  	}
> @@ -4017,14 +4030,12 @@ static void intel_joiner_get_config(struct intel_crtc_state *crtc_state)
>  	u8 primary_pipes, secondary_pipes;
>  	enum pipe pipe = crtc->pipe;
>  
> -	enabled_joiner_pipes(i915, &primary_pipes, &secondary_pipes);
> +	enabled_joiner_pipes(i915, pipe, &primary_pipes, &secondary_pipes);
>  
>  	if (((primary_pipes | secondary_pipes) & BIT(pipe)) == 0)
>  		return;
>  
> -	crtc_state->joiner_pipes =
> -		BIT(get_joiner_primary_pipe(pipe, primary_pipes, secondary_pipes)) |
> -		get_joiner_secondary_pipes(pipe, primary_pipes, secondary_pipes);
> +	crtc_state->joiner_pipes = primary_pipes | secondary_pipes;
>  }
>  
>  static bool hsw_get_pipe_config(struct intel_crtc *crtc,
> -- 
> 2.45.2

-- 
Ville Syrjälä
Intel



[Index of Archives]     [AMD Graphics]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux