On Tue, 20 Aug 2024, Jani Nikula <jani.nikula@xxxxxxxxx> wrote: > Use a Single Point of Truth for display stepping detection instead of > duplicating in i915 and xe. Lucas, Rodrigo, ack for merging this via drm-intel-next? BR, Jani. > > BR, > Jani. > > > Jani Nikula (10): > drm/xe/display: fix compat IS_DISPLAY_STEP() range end > drm/xe/display: remove intel_display_step_name() to simplify > drm/xe/display: remove the unused compat HAS_GMD_ID() > drm/xe/step: define more steppings E-J > drm/i915/display: rename IS_DISPLAY_IP_RANGE() to > IS_DISPLAY_VER_FULL() > drm/i915/display: rename IS_DISPLAY_IP_STEP() to IS_DISPLAY_VER_STEP() > drm/i915/display: identify display steppings in display probe > drm/i915/display: switch to display detected steppings > drm/i915: remove display stepping handling > drm/xe: remove display stepping handling > > .../drm/i915/display/intel_display_device.c | 226 +++++++++++++++++- > .../drm/i915/display/intel_display_device.h | 19 +- > .../drm/i915/display/intel_display_power.c | 2 +- > drivers/gpu/drm/i915/display/intel_dmc.c | 2 +- > drivers/gpu/drm/i915/display/intel_fbc.c | 2 +- > drivers/gpu/drm/i915/display/intel_hdcp.c | 6 +- > drivers/gpu/drm/i915/display/intel_pmdemand.c | 2 +- > drivers/gpu/drm/i915/display/intel_psr.c | 8 +- > drivers/gpu/drm/i915/i915_drv.h | 5 - > drivers/gpu/drm/i915/intel_device_info.c | 1 - > drivers/gpu/drm/i915/intel_step.c | 84 +++---- > drivers/gpu/drm/i915/intel_step.h | 2 - > .../gpu/drm/xe/compat-i915-headers/i915_drv.h | 5 - > .../drm/xe/compat-i915-headers/intel_step.h | 10 +- > drivers/gpu/drm/xe/xe_debugfs.c | 3 +- > drivers/gpu/drm/xe/xe_pci.c | 3 +- > drivers/gpu/drm/xe/xe_step.c | 57 ++--- > drivers/gpu/drm/xe/xe_step_types.h | 30 ++- > 18 files changed, 332 insertions(+), 135 deletions(-) -- Jani Nikula, Intel