> -----Original Message----- > From: Intel-gfx <intel-gfx-bounces@xxxxxxxxxxxxxxxxxxxxx> On Behalf Of Ankit > Nautiyal > Sent: Thursday, July 18, 2024 1:48 PM > To: intel-gfx@xxxxxxxxxxxxxxxxxxxxx > Cc: Lisovskiy, Stanislav <stanislav.lisovskiy@xxxxxxxxx>; Saarinen, Jani > <jani.saarinen@xxxxxxxxx>; ville.syrjala@xxxxxxxxxxxxxxx > Subject: [PATCH 01/12] drm/i915/display: Modify debugfs for joiner to force n > pipes > > At the moment, the debugfs for joiner allows only to force enable/disable pipe > joiner for 2 pipes. Modify it to force join 'n' number of pipes. > This will help in case of ultra joiner where 4 pipes are joined. > I think saying join n number of pipes gives the right idea of what the functionality and Patch is doing. We can only join 2 or 4 pipes I think the commit message should make that clear > Signed-off-by: Ankit Nautiyal <ankit.k.nautiyal@xxxxxxxxx> > --- > .../drm/i915/display/intel_display_debugfs.c | 71 ++++++++++++++++++- > .../drm/i915/display/intel_display_types.h | 8 ++- > drivers/gpu/drm/i915/display/intel_dp.c | 2 +- > 3 files changed, 77 insertions(+), 4 deletions(-) > > diff --git a/drivers/gpu/drm/i915/display/intel_display_debugfs.c > b/drivers/gpu/drm/i915/display/intel_display_debugfs.c > index 5cf9b4af9adf..18f3d83265ce 100644 > --- a/drivers/gpu/drm/i915/display/intel_display_debugfs.c > +++ b/drivers/gpu/drm/i915/display/intel_display_debugfs.c > @@ -1497,6 +1497,73 @@ static int intel_crtc_pipe_show(struct seq_file *m, > void *unused) } DEFINE_SHOW_ATTRIBUTE(intel_crtc_pipe); > > +static int i915_joiner_show(struct seq_file *m, void *data) { > + struct intel_connector *connector = m->private; > + struct drm_i915_private *i915 = to_i915(connector->base.dev); > + int ret; > + > + ret = drm_modeset_lock_single_interruptible(&i915- > >drm.mode_config.connection_mutex); > + if (ret) > + return ret; > + > + seq_printf(m, "Force_joined_pipes: %d\n", > +connector->force_joined_pipes); > + > + drm_modeset_unlock(&i915->drm.mode_config.connection_mutex); > + > + return ret; > +} > + > +static ssize_t i915_joiner_write(struct file *file, > + const char __user *ubuf, > + size_t len, loff_t *offp) > +{ > + struct seq_file *m = file->private_data; > + struct intel_connector *connector = m->private; > + struct drm_i915_private *i915 = to_i915(connector->base.dev); > + int force_join_pipes = 0; > + int ret; > + > + if (len == 0) > + return 0; > + > + drm_dbg(&i915->drm, > + "Copied %zu bytes from user to force joiner\n", len); > + > + ret = kstrtoint_from_user(ubuf, len, 0, &force_join_pipes); > + if (ret < 0) > + return ret; > + > + drm_dbg(&i915->drm, "Got %d for force joining pipes\n", > +force_join_pipes); > + > + if (force_join_pipes < INTEL_PIPE_JOINER_NONE || > + force_join_pipes >= INTEL_PIPE_JOINER_INVALID) { > + drm_dbg(&i915->drm, "Ignoring Invalid num of pipes %d for > force joining\n", > + force_join_pipes); > + connector->force_joined_pipes = INTEL_PIPE_JOINER_NONE; > + } else { > + connector->force_joined_pipes = force_join_pipes; > + } > + > + *offp += len; > + > + return len; > +} > + > +static int i915_joiner_open(struct inode *inode, struct file *file) { > + return single_open(file, i915_joiner_show, inode->i_private); } > + > +static const struct file_operations i915_joiner_fops = { > + .owner = THIS_MODULE, > + .open = i915_joiner_open, > + .read = seq_read, > + .llseek = seq_lseek, > + .release = single_release, > + .write = i915_joiner_write > +}; > + > /** > * intel_connector_debugfs_add - add i915 specific connector debugfs files > * @connector: pointer to a registered intel_connector @@ -1546,8 +1613,8 > @@ void intel_connector_debugfs_add(struct intel_connector *connector) > if (DISPLAY_VER(i915) >= 11 && > (connector_type == DRM_MODE_CONNECTOR_DisplayPort || > connector_type == DRM_MODE_CONNECTOR_eDP)) { > - debugfs_create_bool("i915_bigjoiner_force_enable", 0644, > root, > - &connector->force_bigjoiner_enable); > + debugfs_create_file("i915_joiner_force_enable", 0644, root, > + connector, &i915_joiner_fops); > } > > if (connector_type == DRM_MODE_CONNECTOR_DSI || diff --git > a/drivers/gpu/drm/i915/display/intel_display_types.h > b/drivers/gpu/drm/i915/display/intel_display_types.h > index a9d2acdc51a4..14c78b18ffa1 100644 > --- a/drivers/gpu/drm/i915/display/intel_display_types.h > +++ b/drivers/gpu/drm/i915/display/intel_display_types.h > @@ -613,6 +613,12 @@ struct intel_hdcp { > enum transcoder stream_transcoder; > }; > > +enum intel_joiner_pipe_count { > + INTEL_PIPE_JOINER_NONE = 0, > + INTEL_PIPE_JOINER_BIG = 2, > + INTEL_PIPE_JOINER_INVALID, > +}; Also the naming here should be intel_pipe_joiner_count since the difference in enum variable and enum defines Does not seem right. Also I think the ULTRA enum should be defined sooner rather than later it will help reduce a lot of magic numbers being used in ultrajoiner and big joiner checks later on. > + > struct intel_connector { > struct drm_connector base; > /* > @@ -651,7 +657,7 @@ struct intel_connector { > > struct intel_dp *mst_port; > > - bool force_bigjoiner_enable; > + enum intel_joiner_pipe_count force_joined_pipes; > Naming here should be force_pipes_joined. I think this whole patch series has a trend of naming it as joined pipe I think that should be changed to pipe joined Regards, Suraj Kandpal > struct { > struct drm_dp_aux *dsc_decompression_aux; diff --git > a/drivers/gpu/drm/i915/display/intel_dp.c > b/drivers/gpu/drm/i915/display/intel_dp.c > index d4b1b18453dc..30442c9da06b 100644 > --- a/drivers/gpu/drm/i915/display/intel_dp.c > +++ b/drivers/gpu/drm/i915/display/intel_dp.c > @@ -1164,7 +1164,7 @@ bool intel_dp_need_joiner(struct intel_dp *intel_dp, > return false; > > return clock > i915->display.cdclk.max_dotclk_freq || hdisplay > 5120 > || > - connector->force_bigjoiner_enable; > + connector->force_joined_pipes == INTEL_PIPE_JOINER_BIG; > } > > bool intel_dp_has_dsc(const struct intel_connector *connector) > -- > 2.45.2