On Fri, Jul 05, 2024 at 05:52:40PM +0300, Ville Syrjala wrote: > From: Ville Syrjälä <ville.syrjala@xxxxxxxxxxxxxxx> > > Rename intel_fbc_hw_tracking_covers_screen() to intel_fbc_surface_size_ok() > so that the naming scheme is the same for the surface size vs. plane > size checks. "surface size" is what bspec talks about. Reviewed-by: Rodrigo Vivi <rodrigo.vivi@xxxxxxxxx> > > Signed-off-by: Ville Syrjälä <ville.syrjala@xxxxxxxxxxxxxxx> > --- > drivers/gpu/drm/i915/display/intel_fbc.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/gpu/drm/i915/display/intel_fbc.c b/drivers/gpu/drm/i915/display/intel_fbc.c > index c7fd774440a8..40a3b4937dc5 100644 > --- a/drivers/gpu/drm/i915/display/intel_fbc.c > +++ b/drivers/gpu/drm/i915/display/intel_fbc.c > @@ -1102,7 +1102,7 @@ static void intel_fbc_max_surface_size(struct intel_display *display, > * the X and Y offset registers. That's why we include the src x/y offsets > * instead of just looking at the plane size. > */ > -static bool intel_fbc_hw_tracking_covers_screen(const struct intel_plane_state *plane_state) > +static bool intel_fbc_surface_size_ok(const struct intel_plane_state *plane_state) > { > struct intel_display *display = to_intel_display(plane_state->uapi.plane->dev); > unsigned int effective_w, effective_h, max_w, max_h; > @@ -1354,7 +1354,7 @@ static int intel_fbc_check_plane(struct intel_atomic_state *state, > return 0; > } > > - if (!intel_fbc_hw_tracking_covers_screen(plane_state)) { > + if (!intel_fbc_surface_size_ok(plane_state)) { > plane_state->no_fbc_reason = "surface size too big"; > return 0; > } > -- > 2.44.2 >