On 4/5/2024 9:15 AM, Danilo Krummrich wrote: > Hi Easwar, > > On 3/29/24 18:00, Easwar Hariharan wrote: >> I2C v7, SMBus 3.2, and I3C specifications have replaced "master/slave" >> with more appropriate terms. Inspired by and following on to Wolfram's >> series to fix drivers/i2c/[1], fix the terminology for users of >> I2C_ALGOBIT bitbanging interface, now that the approved verbiage exists >> in the specification. >> >> Compile tested, no functionality changes intended >> >> [1]: https://lore.kernel.org/all/20240322132619.6389-1-wsa+renesas@xxxxxxxxxxxxxxxxxxxx/ >> >> Signed-off-by: Easwar Hariharan <eahariha@xxxxxxxxxxxxxxxxxxx> >> --- >> drivers/gpu/drm/nouveau/dispnv04/dfp.c | 14 +++++++------- >> .../gpu/drm/nouveau/include/nvkm/subdev/bios/dcb.h | 2 +- >> drivers/gpu/drm/nouveau/nouveau_bios.c | 4 ++-- >> 3 files changed, 10 insertions(+), 10 deletions(-) >> >> diff --git a/drivers/gpu/drm/nouveau/dispnv04/dfp.c b/drivers/gpu/drm/nouveau/dispnv04/dfp.c >> index d5b129dc623b..65b791006b19 100644 >> --- a/drivers/gpu/drm/nouveau/dispnv04/dfp.c >> +++ b/drivers/gpu/drm/nouveau/dispnv04/dfp.c >> @@ -149,7 +149,7 @@ void nv04_dfp_update_fp_control(struct drm_encoder *encoder, int mode) >> } >> } >> -static struct drm_encoder *get_tmds_slave(struct drm_encoder *encoder) >> +static struct drm_encoder *get_tmds_client(struct drm_encoder *encoder) >> { >> struct drm_device *dev = encoder->dev; >> struct dcb_output *dcb = nouveau_encoder(encoder)->dcb; >> @@ -172,7 +172,7 @@ static struct drm_encoder *get_tmds_slave(struct drm_encoder *encoder) >> struct dcb_output *slave_dcb = nouveau_encoder(slave)->dcb; >> if (slave_dcb->type == DCB_OUTPUT_TMDS && get_slave_funcs(slave) && >> - slave_dcb->tmdsconf.slave_addr == dcb->tmdsconf.slave_addr) >> + slave_dcb->tmdsconf.client_addr == dcb->tmdsconf.client_addr) >> return slave; > > While, personally, I think master/slave was well suiting for the device relationship > on those busses, I think that if we change it up to conform with the change in > specification, we should make sure to update drivers consistently. > > We should make sure to also change the names of the sourrounding structures and variable > names, otherwise we just make this code harder to read. > > - Danilo > Thanks for the review, and for the appetite to go further! So we are on the same page, you would prefer renaming to controller/target like the feedback on other drm drivers (i915, gma500, radeon)? Thanks, Easwar