On Thu, Feb 08, 2024 at 09:04:45PM +0100, Andi Shyti wrote:
Hi Lucas,
looks good, just one idea...
...
+#define BIT_U8(b) ((u8)(BIT_INPUT_CHECK(u8, b) + BIT(b)))
+#define BIT_U16(b) ((u16)(BIT_INPUT_CHECK(u16, b) + BIT(b)))
+#define BIT_U32(b) ((u32)(BIT_INPUT_CHECK(u32, b) + BIT(b)))
+#define BIT_U64(b) ((u64)(BIT_INPUT_CHECK(u64, b) + BIT(b)))
considering that BIT defines are always referred to unsigned
types, I would just call them
#define BIT8
#define BIT16
#define BIT32
#define BIT64
what do you think?
it will clash with defines from other headers and not match the ones for
GENMASK so I prefer it the other way.
thanks
Lucas De Marchi
Andi