Hi Matt, > +/* > + * Wa_22011802037 requires that we (or the GuC) ensure that no command > + * streamers are executing MI_FORCE_WAKE while an engine reset is initiated. > + */ > +bool intel_engine_reset_needs_wa_22011802037(struct intel_gt *gt) I've seen this format in a recent Jonathan's patch and I see it becoming a pattern in the future. Should we already agree on the naming? Would intel_needs_wa_22011802037() be sufficient? Or a prefix as intel_wa_* for all the similar functions? Andi > +{ > + if (GRAPHICS_VER(gt->i915) < 11) > + return false; > + > + if (IS_MTL_GRAPHICS_STEP(gt->i915, M, STEP_A0, STEP_B0)) > + return true; > + > + if (GRAPHICS_VER_FULL(gt->i915) >= IP_VER(12, 70)) > + return false; > + > + return true; > +}