Up until now we only verified one or two of the dsc pps params like bits_per_component and bits_per_pixel this patch series aim to readout almost all PPS param and get them compared. Along with that some work on making a common function to read and write PPS param regiters is also done. --v2 -Remove duplicated code and create function that fetches register and reuse that. [Jani] -move WARN_ON one abstraction layer up. [Jani] -Split patch so that refactor and a new functionality is not added in the same patch. [Jani] -Add a new refactor patch so that bit shifting can be done in a clean way. [Jani] --v3 -Fix the typo in patch 2 [Jani] -Get both dsc_reg regardless of dsc_eng_no. [Jani] -Remove usage of num_vdsc_instances. [Ankit] -Add macro to further optimize intel_dsc_get_pps_reg --v4 -Manipulate register addresses rather than creating a macro to manipulate variable name based on pps [Ankit] Signed-off-by: Suraj Kandpal <suraj.kandpal@xxxxxxxxx> Acked-by: Jani Nikula <jani.nikula@xxxxxxxxx> Suraj Kandpal (7): drm/i915/vdsc: Refactor dsc register field macro drm/i915/vdsc: Add a check for dsc split cases drm/i915/vdsc: Add function to read any PPS register drm/i915/vdsc: Add function to write in PPS register drm/i915/vdsc: Remove unused dsc registers drm/i915/vdsc: Fill the intel_dsc_get_pps_config function drm/i915/display: Compare the readout dsc pps params drivers/gpu/drm/i915/display/intel_display.c | 31 ++ drivers/gpu/drm/i915/display/intel_vdsc.c | 448 ++++++++---------- .../gpu/drm/i915/display/intel_vdsc_regs.h | 366 +++++--------- 3 files changed, 322 insertions(+), 523 deletions(-) -- 2.25.1