On Thu, 13 Jul 2023, Suraj Kandpal <suraj.kandpal@xxxxxxxxx> wrote: > Up until now we only verified one or two of the dsc pps > params like bits_per_component and bits_per_pixel this > patch series aim to readout almost all PPS param and get > them compared. > Along with that some work on making a common function to > read and write PPS param regiters is also done. There are some issues that I noted, and I'm sure some things could be done differently, but overall I think this makes nice improvements, and it's definitely better than the first version. The further versions will still require detailed review, but the overall approach is now Acked-by: Jani Nikula <jani.nikula@xxxxxxxxx> > > --v2 > -Remove duplicated code and create function that fetches register > and reuse that [Jani] > -move WARN_ON one abstraction layer up [Jani] > -Split patch so that refactor and a new functionality is not added > in the same patch [Jani] > -Add a new refactor patch so that bit shifting can be done in a > clean way [Jani] > > Signed-off-by: Suraj Kandpal <suraj.kandpal@xxxxxxxxx> > > Suraj Kandpal (6): > drm/i915/vdsc: Refactor dsc register field macro > drm/i915/vdsc: Add a check for dsc split cases > drm/i915/vdsc: Add function to read any PPS register > drm/i915/vdsc: Add function to write in PPS register > drm/i915/vdsc: Fill the intel_dsc_get_pps_config function > drm/i915/display: Compare the readout dsc pps params > > drivers/gpu/drm/i915/display/intel_display.c | 31 + > drivers/gpu/drm/i915/display/intel_vdsc.c | 622 ++++++++++-------- > .../gpu/drm/i915/display/intel_vdsc_regs.h | 101 ++- > 3 files changed, 463 insertions(+), 291 deletions(-) -- Jani Nikula, Intel Open Source Graphics Center