On Tue, 30 May 2023, Anusha Srivatsa <anusha.srivatsa@xxxxxxxxx> wrote: > Follow consistent naming convention. Replace ADLP with > ALDERLAKE_P. Here too the consistent naming convention for all macros using IS_SUBPLATFORM() is to use the acronym. The IS_METEORLAKE_M() and IS_METEORLAKE_P() macros are the outliers. Again, do you suggest we rename all of them, or just ADL-P? The former is a lot of churn, and the latter is not consistent. BR, Jani. > > Signed-off-by: Anusha Srivatsa <anusha.srivatsa@xxxxxxxxx> > --- > drivers/gpu/drm/i915/i915_drv.h | 2 +- > drivers/gpu/drm/i915/intel_step.c | 2 +- > 2 files changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/gpu/drm/i915/i915_drv.h b/drivers/gpu/drm/i915/i915_drv.h > index 1a50b8b2f00d..43414cdc137c 100644 > --- a/drivers/gpu/drm/i915/i915_drv.h > +++ b/drivers/gpu/drm/i915/i915_drv.h > @@ -581,7 +581,7 @@ IS_SUBPLATFORM(const struct drm_i915_private *i915, > IS_SUBPLATFORM(i915, INTEL_ALDERLAKE_S, INTEL_SUBPLATFORM_RPL) > #define IS_ADLP_N(i915) \ > IS_SUBPLATFORM(i915, INTEL_ALDERLAKE_P, INTEL_SUBPLATFORM_N) > -#define IS_ADLP_RPLP(i915) \ > +#define IS_ALDERLAKE_P_RPLP(i915) \ > IS_SUBPLATFORM(i915, INTEL_ALDERLAKE_P, INTEL_SUBPLATFORM_RPL) > #define IS_ADLP_RPLU(i915) \ > IS_SUBPLATFORM(i915, INTEL_ALDERLAKE_P, INTEL_SUBPLATFORM_RPLU) > diff --git a/drivers/gpu/drm/i915/intel_step.c b/drivers/gpu/drm/i915/intel_step.c > index 8a9ff6227e53..10d86c525beb 100644 > --- a/drivers/gpu/drm/i915/intel_step.c > +++ b/drivers/gpu/drm/i915/intel_step.c > @@ -195,7 +195,7 @@ void intel_step_init(struct drm_i915_private *i915) > } else if (IS_ADLP_N(i915)) { > revids = adlp_n_revids; > size = ARRAY_SIZE(adlp_n_revids); > - } else if (IS_ADLP_RPLP(i915)) { > + } else if (IS_ALDERLAKE_P_RPLP(i915)) { > revids = adlp_rplp_revids; > size = ARRAY_SIZE(adlp_rplp_revids); > } else if (IS_ALDERLAKE_P(i915)) { -- Jani Nikula, Intel Open Source Graphics Center