Re: [PATCH] drm/i915/mtl: Add support for PM DEMAND

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, 12 Apr 2023, Gustavo Sousa <gustavo.sousa@xxxxxxxxx> wrote:
> Quoting Jani Nikula (2023-04-12 06:33:54)
>> On Tue, 11 Apr 2023, Gustavo Sousa <gustavo.sousa@xxxxxxxxx> wrote:
>> > Quoting Mika Kahola (2023-04-03 05:50:43)
>> >> @@ -8250,6 +8259,7 @@ void intel_init_display_hooks(struct drm_i915_private *dev_priv)
>> >>         intel_color_init_hooks(dev_priv);
>> >>         intel_init_cdclk_hooks(dev_priv);
>> >>         intel_audio_hooks_init(dev_priv);
>> >> +  intel_init_pmdemand(dev_priv);
>> >
>> > I think intel_init_display_hooks() is meant to call functions setting up
>> > function pointers, right? That would not be the case for intel_init_pmdemand().
>> >
>> > I think we could rename intel_init_pmdemand() to
>> > intel_pmdemand_init_early() and call it inside i915_driver_early_probe().
>> 
>> Please let's not add new direct calls to display from top level driver
>> code. See also [1].
>
> Okay. What would be the suggested place to do this SW-only initialization?
>
> Should we just merge the two init functions into one named intel_pmdemand_init()
> and call the new function under intel_modeset_init_noirq()?

Or add a new function intel_display_early_probe() or somesuch, which
will call the early pmdemand init as well as intel_init_display_hooks()
that is currently called from i915_driver_early_probe().

Bottom line, there should only be one high level call from
i915_driver_early_probe().

There are similar needs for other things [1].

BR,
Jani.


[1] https://lore.kernel.org/r/20230411195918.hdxyir5w7dp2qx55@xxxxxxxxxxxxxxxxxx


>
> --
> Gustavo Sousa

-- 
Jani Nikula, Intel Open Source Graphics Center



[Index of Archives]     [AMD Graphics]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux