> > > > > -----Original Message----- > > From: Kandpal, Suraj <suraj.kandpal@xxxxxxxxx> > > Sent: Wednesday, February 1, 2023 2:38 PM > > To: intel-gfx@xxxxxxxxxxxxxxxxxxxxx > > Cc: Nautiyal, Ankit K <ankit.k.nautiyal@xxxxxxxxx>; Kandpal, Suraj > > <suraj.kandpal@xxxxxxxxx>; Winkler, Tomas <tomas.winkler@xxxxxxxxx>; > > Vivi, Rodrigo <rodrigo.vivi@xxxxxxxxx>; Shankar, Uma > > <uma.shankar@xxxxxxxxx>; Gupta, Anshuman > <anshuman.gupta@xxxxxxxxx> > > Subject: [PATCH v10 3/6] i915/hdcp: HDCP2.x Refactoring to agnostic > > hdcp > > Prefix drm. > Sure > > As now we have more then one type of content protection secrity > > firmware. Let > > Typo in security > Will fix > > change the i915_hdcp_interface.h header naming convention to suit > > generic f/w type. > > %s/MEI_/HDCP_ > > %s/mei_dev/hdcp_dev > > > > As interface to CP FW can be either a non i915 component or > > i915 intergral component, change structure name Accordingly. > > %s/i915_hdcp_comp_master/i915_hdcp_master > > %s/i915_hdcp_component_ops/i915_hdcp_ops > > Description seems to be off from the changes in the patch. Please fix. > > > --v3 > > -Changing names to drop cp_fw to make naming more agnostic[Jani] > > > > Cc: Tomas Winkler <tomas.winkler@xxxxxxxxx> > > Cc: Rodrigo Vivi <rodrigo.vivi@xxxxxxxxx> > > Cc: Uma Shankar <uma.shankar@xxxxxxxxx> > > Cc: Ankit Nautiyal <ankit.k.nautiyal@xxxxxxxxx> > > Signed-off-by: Anshuman Gupta <anshuman.gupta@xxxxxxxxx> > > Signed-off-by: Suraj Kandpal <suraj.kandpal@xxxxxxxxx> > > Reviewed-by: Ankit Nautiyal <ankit.k.nautiyal@xxxxxxxxx> > > --- > > drivers/gpu/drm/i915/display/intel_display_core.h | 1 + > > drivers/gpu/drm/i915/display/intel_hdcp.c | 4 ++-- > > 2 files changed, 3 insertions(+), 2 deletions(-) > > > > diff --git a/drivers/gpu/drm/i915/display/intel_display_core.h > > b/drivers/gpu/drm/i915/display/intel_display_core.h > > index 8e7a68339876..139100fe2383 100644 > > --- a/drivers/gpu/drm/i915/display/intel_display_core.h > > +++ b/drivers/gpu/drm/i915/display/intel_display_core.h > > @@ -15,6 +15,7 @@ > > > > #include <drm/drm_connector.h> > > #include <drm/drm_modeset_lock.h> > > +#include <drm/i915_hdcp_interface.h> > > This change doesn't seem to affect the changes below. Please move this to > the right patch. Okay got it Regards, Suraj Kandpal > > > > > #include "intel_cdclk.h" > > #include "intel_display_limits.h" > > diff --git a/drivers/gpu/drm/i915/display/intel_hdcp.c > > b/drivers/gpu/drm/i915/display/intel_hdcp.c > > index 262c76f21801..0d6aed1eb171 100644 > > --- a/drivers/gpu/drm/i915/display/intel_hdcp.c > > +++ b/drivers/gpu/drm/i915/display/intel_hdcp.c > > @@ -1409,7 +1409,7 @@ static int hdcp2_authenticate_port(struct > > intel_connector > > *connector) > > return ret; > > } > > > > -static int hdcp2_close_mei_session(struct intel_connector *connector) > > +static int hdcp2_close_session(struct intel_connector *connector) > > { > > struct intel_digital_port *dig_port = > intel_attached_dig_port(connector); > > struct drm_i915_private *dev_priv = to_i915(connector->base.dev); > @@ > > - > > 1433,7 +1433,7 @@ static int hdcp2_close_mei_session(struct > > intel_connector > > *connector) > > > > static int hdcp2_deauthenticate_port(struct intel_connector *connector) { > > - return hdcp2_close_mei_session(connector); > > + return hdcp2_close_session(connector); > > } > > > > /* Authentication flow starts from here */ > > -- > > 2.25.1