> From: Jason Gunthorpe <jgg@xxxxxxxxxx> > Sent: Tuesday, February 28, 2023 9:26 PM > > On Tue, Feb 28, 2023 at 01:22:50PM +0000, Liu, Yi L wrote: > > > > A null iommufd pointer and a bound df flag is sufficient to see that > > > it is compat mode. > > > > Hope df->is_cdev_device suits your expectation.:-) The code will look > > like below: > > Yes, this is better.. However I'd suggest 'uses_container' as it is > clearer what the special case is Surely doable. Need to add a helper like below: bool vfio_device_group_uses_container() { lockdep_assert_held(&device->group->group_lock); return device->group->container; } But I'm poor at naming it. If it is true, the code would call vfio_device_group_use_iommu(). If doing it in this way, I think it's better to rename vfio_device_group_use_iommu() as well. Regards, Yi Liu