On Tue, Jan 10, 2023 at 11:45:02PM +0530, Deepak R Varma wrote: > Using DEFINE_SIMPLE_ATTRIBUTE macro with the debugfs_create_file() > function adds the overhead of introducing a proxy file operation > functions to wrap the original read/write inside file removal protection > functions. This adds significant overhead in terms of introducing and > managing the proxy factory file operations structure and function > wrapping at runtime. > As a replacement, a combination of DEFINE_DEBUGFS_ATTRIBUTE macro paired > with debugfs_create_file_unsafe() is suggested to be used instead. The > DEFINE_DEBUGFS_ATTRIBUTE utilises debugfs_file_get() and > debugfs_file_put() wrappers to protect the original read and write > function calls for the debug attributes. There is no need for any > runtime proxy file operations to be managed by the debugfs core. > Following coccicheck make command helped identify this change: > > make coccicheck M=drivers/gpu/drm/i915/ MODE=patch COCCI=./scripts/coccinelle/api/debugfs/debugfs_simple_attr.cocci > > Signed-off-by: Deepak R Varma <drv@xxxxxxxxx> > --- > Changes in v2: > - Include coccicheck make command in the patch log message for clarity. > Suggested by Rodrigo Vivi <rodrigo.vivi@xxxxxxxxx> Thank you Reviewed-by: Rodrigo Vivi <rodrigo.vivi@xxxxxxxxx> > > drivers/gpu/drm/i915/display/intel_drrs.c | 8 ++++---- > 1 file changed, 4 insertions(+), 4 deletions(-) > > diff --git a/drivers/gpu/drm/i915/display/intel_drrs.c b/drivers/gpu/drm/i915/display/intel_drrs.c > index 5b9e44443814..84ba7379d6f8 100644 > --- a/drivers/gpu/drm/i915/display/intel_drrs.c > +++ b/drivers/gpu/drm/i915/display/intel_drrs.c > @@ -374,16 +374,16 @@ static int intel_drrs_debugfs_ctl_set(void *data, u64 val) > return ret; > } > > -DEFINE_SIMPLE_ATTRIBUTE(intel_drrs_debugfs_ctl_fops, > - NULL, intel_drrs_debugfs_ctl_set, "%llu\n"); > +DEFINE_DEBUGFS_ATTRIBUTE(intel_drrs_debugfs_ctl_fops, > + NULL, intel_drrs_debugfs_ctl_set, "%llu\n"); > > void intel_drrs_crtc_debugfs_add(struct intel_crtc *crtc) > { > debugfs_create_file("i915_drrs_status", 0444, crtc->base.debugfs_entry, > crtc, &intel_drrs_debugfs_status_fops); > > - debugfs_create_file("i915_drrs_ctl", 0644, crtc->base.debugfs_entry, > - crtc, &intel_drrs_debugfs_ctl_fops); > + debugfs_create_file_unsafe("i915_drrs_ctl", 0644, crtc->base.debugfs_entry, > + crtc, &intel_drrs_debugfs_ctl_fops); > } > > static int intel_drrs_debugfs_type_show(struct seq_file *m, void *unused) > -- > 2.34.1 > > >