Hi, Here's a series aiming at improving the command line named modes support, and more importantly how we deal with all the analog TV variants. The named modes support were initially introduced to allow to specify the analog TV mode to be used. However, this was causing multiple issues: * The mode name parsed on the command line was passed directly to the driver, which had to figure out which mode it was suppose to match; * Figuring that out wasn't really easy, since the video= argument or what the userspace might not even have a name in the first place, but instead could have passed a mode with the same timings; * The fallback to matching on the timings was mostly working as long as we were supporting one 525 lines (most likely NSTC) and one 625 lines (PAL), but couldn't differentiate between two modes with the same timings (NTSC vs PAL-M vs NSTC-J for example); * There was also some overlap with the tv mode property registered by drm_mode_create_tv_properties(), but named modes weren't interacting with that property at all. * Even though that property was generic, its possible values were specific to each drivers, which made some generic support difficult. Thus, I chose to tackle in multiple steps: * A new TV mode property was introduced, with generic values, each driver reporting through a bitmask what standard it supports to the userspace; * This option was added to the command line parsing code to be able to specify it on the kernel command line, and new atomic_check and reset helpers were created to integrate properly into atomic KMS; * The named mode parsing code is now creating a proper display mode for the given named mode, and the TV standard will thus be part of the connector state; * Two drivers were converted and tested for now (vc4 and sun4i), with some backward compatibility code to translate the old TV mode to the new TV mode; Unit tests were created along the way. One can switch from NTSC to PAL now using (on vc4) modetest -M vc4 -s 53:720x480i -w 53:'TV mode':1 # NTSC modetest -M vc4 -s 53:720x576i -w 53:'TV mode':4 # PAL Let me know what you think, Maxime To: David Airlie <airlied@xxxxxxxx> To: Daniel Vetter <daniel@xxxxxxxx> To: Maarten Lankhorst <maarten.lankhorst@xxxxxxxxxxxxxxx> To: Maxime Ripard <mripard@xxxxxxxxxx> To: Thomas Zimmermann <tzimmermann@xxxxxxx> To: Emma Anholt <emma@xxxxxxxxxx> To: Jani Nikula <jani.nikula@xxxxxxxxxxxxxxx> To: Joonas Lahtinen <joonas.lahtinen@xxxxxxxxxxxxxxx> To: Rodrigo Vivi <rodrigo.vivi@xxxxxxxxx> To: Tvrtko Ursulin <tvrtko.ursulin@xxxxxxxxxxxxxxx> To: Ben Skeggs <bskeggs@xxxxxxxxxx> To: Karol Herbst <kherbst@xxxxxxxxxx> To: Lyude Paul <lyude@xxxxxxxxxx> To: Chen-Yu Tsai <wens@xxxxxxxx> To: Jernej Skrabec <jernej.skrabec@xxxxxxxxx> To: Samuel Holland <samuel@xxxxxxxxxxxx> Cc: Geert Uytterhoeven <geert@xxxxxxxxxxxxxx> Cc: Mateusz Kwiatkowski <kfyatek+publicgit@xxxxxxxxx> Cc: "Noralf Trønnes" <noralf@xxxxxxxxxxx> Cc: Dave Stevenson <dave.stevenson@xxxxxxxxxxxxxxx> Cc: Dom Cobley <dom@xxxxxxxxxxxxxxx> Cc: Phil Elwell <phil@xxxxxxxxxxxxxxx> Cc: <dri-devel@xxxxxxxxxxxxxxxxxxxxx> Cc: linux-kernel@xxxxxxxxxxxxxxx Cc: intel-gfx@xxxxxxxxxxxxxxxxxxxxx Cc: nouveau@xxxxxxxxxxxxxxxxxxxxx Cc: linux-arm-kernel@xxxxxxxxxxxxxxxxxxx Cc: linux-sunxi@xxxxxxxxxxxxxxx Cc: Hans de Goede <hdegoede@xxxxxxxxxx> Signed-off-by: Maxime Ripard <maxime@xxxxxxxxxx> --- Changes in v3: - Applied some of the fixes to vc4 and sun4i - Renamed the old TV mode property to legacy_mode - Fixed a bunch of bisection errors - Removed most of the redundant TV modes - Added a new None TV mode to not fall back on NTSC by mistake - Fixed the mode generation function to match better what is expected - Added some logging to the mode generation function - Split the improvements to the named mode parsing logic into separate patches - Added more checks to the TV atomic_check helper - Link to v2: https://lore.kernel.org/dri-devel/20220728-rpi-analog-tv-properties-v2-0-459522d653a7@xxxxxxxxxx/ Changes in v2: - Kept the older TV mode property as legacy so we can keep the old drivers functional - Renamed the tv_norm property to tv_mode - Added a function to create PAL and NTSC compatible display modes - Added some helpers to instantiate a mock DRM device in Kunit - More Kunit tests - Removed the HD analog TV modes - Renamed some of the tests - Renamed some of the named modes - Fixed typos in commit logs - Added the various tags - Link to v1: https://lore.kernel.org/dri-devel/20220728-rpi-analog-tv-properties-v1-0-3d53ae722097@xxxxxxxxxx/ --- Geert Uytterhoeven (1): drm/modes: parse_cmdline: Add support for named modes containing dashes Mateusz Kwiatkowski (3): drm/vc4: vec: Fix definition of PAL-M mode drm/vc4: vec: Check for VEC output constraints drm/vc4: vec: Add support for more analog TV standards Maxime Ripard (29): drm/tests: Order Kunit tests in Makefile drm/tests: Add Kunit Helpers drm/atomic-helper: Rename drm_atomic_helper_connector_tv_reset to avoid ambiguity drm/connector: Rename subconnector state variable drm/atomic: Add TV subconnector property to get/set_property drm/connector: Rename legacy TV property drm/connector: Only register TV mode property if present drm/connector: Rename drm_mode_create_tv_properties drm/connector: Add TV standard property drm/modes: Add a function to generate analog display modes drm/modes: Only consider bpp and refresh before options drm/client: Add some tests for drm_connector_pick_cmdline_mode() drm/modes: Move named modes parsing to a separate function drm/modes: Bail out of named mode parsing if empty drm/modes: Bail out of named mode parsing early if it's a number drm/modes: Bail out of named mode parsing early if it's an option drm/modes: Bail out of named mode parsing early if it's a status drm/modes: Switch to named mode descriptors drm/modes: Fill drm_cmdline mode from named modes drm/connector: Add pixel clock to cmdline mode drm/connector: Add a function to lookup a TV mode by its name drm/modes: Introduce the tv_mode property as a command-line option drm/modes: Properly generate a drm_display_mode from a named mode drm/modes: Introduce more named modes drm/atomic-helper: Add a TV properties reset helper drm/atomic-helper: Add an analog TV atomic_check implementation drm/vc4: vec: Use TV Reset implementation drm/vc4: vec: Convert to the new TV mode property drm/sun4i: tv: Convert to the new TV mode property drivers/gpu/drm/drm_atomic_state_helper.c | 128 ++++- drivers/gpu/drm/drm_atomic_uapi.c | 8 + drivers/gpu/drm/drm_client_modeset.c | 4 + drivers/gpu/drm/drm_connector.c | 111 +++- drivers/gpu/drm/drm_modes.c | 658 +++++++++++++++++++++++- drivers/gpu/drm/gud/gud_connector.c | 12 +- drivers/gpu/drm/i2c/ch7006_drv.c | 6 +- drivers/gpu/drm/i915/display/intel_tv.c | 5 +- drivers/gpu/drm/nouveau/dispnv04/tvnv17.c | 6 +- drivers/gpu/drm/sun4i/sun4i_tv.c | 148 ++---- drivers/gpu/drm/tests/Makefile | 16 +- drivers/gpu/drm/tests/drm_client_modeset_test.c | 239 +++++++++ drivers/gpu/drm/tests/drm_cmdline_parser_test.c | 67 +++ drivers/gpu/drm/tests/drm_kunit_helpers.c | 54 ++ drivers/gpu/drm/tests/drm_kunit_helpers.h | 9 + drivers/gpu/drm/tests/drm_modes_test.c | 136 +++++ drivers/gpu/drm/vc4/vc4_hdmi.c | 2 +- drivers/gpu/drm/vc4/vc4_vec.c | 339 ++++++++++-- include/drm/drm_atomic_state_helper.h | 4 + include/drm/drm_connector.h | 92 +++- include/drm/drm_mode_config.h | 12 +- include/drm/drm_modes.h | 17 + 22 files changed, 1866 insertions(+), 207 deletions(-) --- base-commit: 9f5ef9111a4c973a69f9ba22ac73f1f9c634baf6 change-id: 20220728-rpi-analog-tv-properties-0914dfcee460 Best regards, -- Maxime Ripard <maxime@xxxxxxxxxx>