From: John Harrison <John.C.Harrison@xxxxxxxxx> The next GuC firmware release includes some significant backwards breaking API changes. One such is that there is no longer an LRC descriptor pool. A bunch of prep work for that change can be done in advance - the descriptor pool was being used for things it shouldn't really have been used for anyway. v2: Extend commit message on 'better name' patch. Improve 'split apart' patch to include some necessary re-arrangement that was in a later patch and which introduced an unnecessary conditional in said patch too. (review feedback from Daniele) v3: Rebase to newer tree. Signed-off-by: John Harrison <John.C.Harrison@xxxxxxxxx> John Harrison (8): drm/i915/guc: Do not conflate lrc_desc with GuC id for registration drm/i915/guc: Add an explicit 'submission_initialized' flag drm/i915/guc: Better name for context id limit drm/i915/guc: Split guc_lrc_desc_pin apart drm/i915/guc: Move lrc desc setup to where it is needed drm/i915/guc: Rename desc_idx to ctx_id drm/i915/guc: Drop obsolete H2G definitions drm/i915/guc: Fix potential invalid pointer dereferences when decoding G2Hs drivers/gpu/drm/i915/gt/intel_context.c | 2 +- .../gpu/drm/i915/gt/uc/abi/guc_actions_abi.h | 2 - drivers/gpu/drm/i915/gt/uc/intel_guc.h | 2 + drivers/gpu/drm/i915/gt/uc/intel_guc_fwif.h | 4 +- .../gpu/drm/i915/gt/uc/intel_guc_submission.c | 181 ++++++++++-------- drivers/gpu/drm/i915/gt/uc/selftest_guc.c | 2 +- 6 files changed, 109 insertions(+), 84 deletions(-) -- 2.25.1