On Wed, Feb 16, 2022 at 11:38:44AM +0200, Jani Nikula wrote: > On Fri, 11 Feb 2022, Ville Syrjala <ville.syrjala@xxxxxxxxxxxxxxx> wrote: > > From: Ville Syrjälä <ville.syrjala@xxxxxxxxxxxxxxx> > > > > No reason the high level intel_update_crtc() needs to know > > that there is something magical about the commit order of > > planes between different platforms. So let's hide that > > detail even better. > > > > Signed-off-by: Ville Syrjälä <ville.syrjala@xxxxxxxxxxxxxxx> > > --- > > .../gpu/drm/i915/display/intel_atomic_plane.c | 19 +++++++++++++++---- > > .../gpu/drm/i915/display/intel_atomic_plane.h | 6 ++---- > > drivers/gpu/drm/i915/display/intel_display.c | 6 +----- > > 3 files changed, 18 insertions(+), 13 deletions(-) > > > > diff --git a/drivers/gpu/drm/i915/display/intel_atomic_plane.c b/drivers/gpu/drm/i915/display/intel_atomic_plane.c > > index 3355eb637eac..bba2f105b7dd 100644 > > --- a/drivers/gpu/drm/i915/display/intel_atomic_plane.c > > +++ b/drivers/gpu/drm/i915/display/intel_atomic_plane.c > > @@ -716,8 +716,8 @@ void intel_update_planes_on_crtc(struct intel_atomic_state *state, > > } > > } > > > > -void skl_arm_planes_on_crtc(struct intel_atomic_state *state, > > - struct intel_crtc *crtc) > > +static void skl_arm_planes_on_crtc(struct intel_atomic_state *state, > > + struct intel_crtc *crtc) > > { > > struct intel_crtc_state *old_crtc_state = > > intel_atomic_get_old_crtc_state(state, crtc); > > @@ -751,8 +751,8 @@ void skl_arm_planes_on_crtc(struct intel_atomic_state *state, > > } > > } > > > > -void i9xx_arm_planes_on_crtc(struct intel_atomic_state *state, > > - struct intel_crtc *crtc) > > +static void i9xx_arm_planes_on_crtc(struct intel_atomic_state *state, > > + struct intel_crtc *crtc) > > { > > struct intel_crtc_state *new_crtc_state = > > intel_atomic_get_new_crtc_state(state, crtc); > > @@ -777,6 +777,17 @@ void i9xx_arm_planes_on_crtc(struct intel_atomic_state *state, > > } > > } > > > > +void intel_arm_planes_on_crtc(struct intel_atomic_state *state, > > + struct intel_crtc *crtc) > > +{ > > I don't much like the intel_arm_ prefix here. I'd go for intel_plane_ > something or other. intel_plane_ is rather bad since this operates on multiple planes. Though I'm not super happy with the _arm_ vs. _update_ thing we have going on now. The plane hooks I made .update_noarm() and .update_arm() (which certainly has a few bad puns in it) so should perhaps just try to follow a similar naming convention for the high level stuff. I guess I'd prefer intel_crtc_ as the prefix actually since thats what we pass in anyway. -- Ville Syrjälä Intel