Using local pointer ttm as argument in __i915_ttm_move instead of bo->ttm, as local pointer was previously assigned to bo->ttm in function. This will make code a bit more readable. Signed-off-by: Jasmine Newsome <jasmine.newsome@xxxxxxxxx> --- drivers/gpu/drm/i915/gem/i915_gem_ttm_move.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/i915/gem/i915_gem_ttm_move.c b/drivers/gpu/drm/i915/gem/i915_gem_ttm_move.c index 80df9f592407..56b6573b5c93 100644 --- a/drivers/gpu/drm/i915/gem/i915_gem_ttm_move.c +++ b/drivers/gpu/drm/i915/gem/i915_gem_ttm_move.c @@ -763,7 +763,7 @@ int i915_ttm_move(struct ttm_buffer_object *bo, bool evict, return PTR_ERR(dep); } - migration_fence = __i915_ttm_move(bo, clear, dst_mem, bo->ttm, + migration_fence = __i915_ttm_move(bo, clear, dst_mem, ttm, dst_rsgt, true, dep); dma_fence_put(dep); } -- 2.25.1