On Thu, Oct 14, 2021 at 01:28:56PM +0300, Jani Nikula wrote: > Split out the sbi and pcode code to separate files. > > There's potential for follow-up work that's not included here: > > - vlv_sideband, intel_sbi and intel_pcode all use > i915->sb_lock. Technically it's fine, but the appearance is confusing. > > - The pcode function naming could use some cleanup. > > - Slightly unrelated, all the functions in intel_display.c using > intel_sbi should be moved out of intel_display.c as a group. I was initialy thinking to just shovel it into intel_fdi.c since that's more or less the only user atm. But after another thought intel_pch_refclk.c could be a decent idea. The related ibx/cpt/ppt code could go there as well. > > > BR, > Jani. > > Cc: Ville Syrjälä <ville.syrjala@xxxxxxxxxxxxxxx> > > Jani Nikula (2): > drm/i915: split out intel_pcode.[ch] to separate file > drm/i915: rename intel_sideband.[ch] to intel_sbi.[ch] Series is Reviewed-by: Ville Syrjälä <ville.syrjala@xxxxxxxxxxxxxxx> > > drivers/gpu/drm/i915/Makefile | 3 +- > drivers/gpu/drm/i915/display/intel_bw.c | 2 +- > drivers/gpu/drm/i915/display/intel_cdclk.c | 2 +- > drivers/gpu/drm/i915/display/intel_display.c | 5 +- > .../drm/i915/display/intel_display_power.c | 2 +- > drivers/gpu/drm/i915/display/intel_fdi.c | 2 +- > drivers/gpu/drm/i915/display/intel_hdcp.c | 6 +- > drivers/gpu/drm/i915/gt/intel_gt_pm_debugfs.c | 2 +- > drivers/gpu/drm/i915/gt/intel_llc.c | 2 +- > drivers/gpu/drm/i915/gt/intel_rc6.c | 2 +- > drivers/gpu/drm/i915/gt/intel_rps.c | 2 +- > drivers/gpu/drm/i915/i915_drv.c | 2 +- > drivers/gpu/drm/i915/intel_dram.c | 2 +- > .../i915/{intel_sideband.c => intel_pcode.c} | 91 +------------------ > .../i915/{intel_sideband.h => intel_pcode.h} | 19 ++-- > drivers/gpu/drm/i915/intel_pm.c | 2 +- > drivers/gpu/drm/i915/intel_sbi.c | 73 +++++++++++++++ > drivers/gpu/drm/i915/intel_sbi.h | 23 +++++ > 18 files changed, 124 insertions(+), 118 deletions(-) > rename drivers/gpu/drm/i915/{intel_sideband.c => intel_pcode.c} (69%) > rename drivers/gpu/drm/i915/{intel_sideband.h => intel_pcode.h} (63%) > create mode 100644 drivers/gpu/drm/i915/intel_sbi.c > create mode 100644 drivers/gpu/drm/i915/intel_sbi.h > > -- > 2.30.2 -- Ville Syrjälä Intel