On Tue, Oct 27, 2020 at 10:09:20PM +0200, Ville Syrjälä wrote: > On Tue, Oct 27, 2020 at 12:30:33PM -0700, Manasi Navare wrote: > > No functional changes just use hw_mode to retrive > > hw.adjusted_mode during HW state readout for clarity > > in bigjoiner case. > > Still don't understnad what this has to do with bigjoiner. Looks > like a simple introduction of a strangely named local variable to > me? SHould I just drop this then? Or just reword the commit message to remove bigjoiner related stuff? Manasi > > > > > Signed-off-by: Manasi Navare <manasi.d.navare@xxxxxxxxx> > > --- > > drivers/gpu/drm/i915/display/intel_display.c | 22 +++++++++++--------- > > 1 file changed, 12 insertions(+), 10 deletions(-) > > > > diff --git a/drivers/gpu/drm/i915/display/intel_display.c b/drivers/gpu/drm/i915/display/intel_display.c > > index cabda5a02e9e..b000dd68977f 100644 > > --- a/drivers/gpu/drm/i915/display/intel_display.c > > +++ b/drivers/gpu/drm/i915/display/intel_display.c > > @@ -9119,20 +9119,22 @@ static void intel_get_pipe_src_size(struct intel_crtc *crtc, > > void intel_mode_from_pipe_config(struct drm_display_mode *mode, > > struct intel_crtc_state *pipe_config) > > { > > - mode->hdisplay = pipe_config->hw.adjusted_mode.crtc_hdisplay; > > - mode->htotal = pipe_config->hw.adjusted_mode.crtc_htotal; > > - mode->hsync_start = pipe_config->hw.adjusted_mode.crtc_hsync_start; > > - mode->hsync_end = pipe_config->hw.adjusted_mode.crtc_hsync_end; > > + struct drm_display_mode *hw_mode = &pipe_config->hw.adjusted_mode; > > > > - mode->vdisplay = pipe_config->hw.adjusted_mode.crtc_vdisplay; > > - mode->vtotal = pipe_config->hw.adjusted_mode.crtc_vtotal; > > - mode->vsync_start = pipe_config->hw.adjusted_mode.crtc_vsync_start; > > - mode->vsync_end = pipe_config->hw.adjusted_mode.crtc_vsync_end; > > + mode->hdisplay = hw_mode->crtc_hdisplay; > > + mode->htotal = hw_mode->crtc_htotal; > > + mode->hsync_start = hw_mode->crtc_hsync_start; > > + mode->hsync_end = hw_mode->crtc_hsync_end; > > > > - mode->flags = pipe_config->hw.adjusted_mode.flags; > > + mode->vdisplay = hw_mode->crtc_vdisplay; > > + mode->vtotal = hw_mode->crtc_vtotal; > > + mode->vsync_start = hw_mode->crtc_vsync_start; > > + mode->vsync_end = hw_mode->crtc_vsync_end; > > + > > + mode->flags = hw_mode->flags; > > mode->type = DRM_MODE_TYPE_DRIVER; > > > > - mode->clock = pipe_config->hw.adjusted_mode.crtc_clock; > > + mode->clock = hw_mode->crtc_clock; > > > > drm_mode_set_name(mode); > > } > > -- > > 2.19.1 > > > > _______________________________________________ > > Intel-gfx mailing list > > Intel-gfx@xxxxxxxxxxxxxxxxxxxxx > > https://lists.freedesktop.org/mailman/listinfo/intel-gfx > > -- > Ville Syrjälä > Intel _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx