The hardware architects have finally provided an updated MMIO table for gen12 platforms (TGL, RKL, DG1). We should update our driver's forcewake and MCR programming accordingly. v2: - Include a rename of FORCEWAKE_BLITTER to FORCEWAKE_GT - Add comments to aggregated forcewake ranges showing the sub-ranges that we've combined. (Jose) Bspec: 66696 Cc: Caz Yokoyama <caz.yokoyama@xxxxxxxxx> Cc: Daniele Ceraolo Spurio <daniele.ceraolospurio@xxxxxxxxx> Cc: José Roberto de Souza <jose.souza@xxxxxxxxx> Matt Roper (3): drm/i915: Rename FORCEWAKE_BLITTER to FORCEWAKE_GT drm/i915: Update gen12 forcewake table drm/i915: Update gen12 multicast register ranges drivers/gpu/drm/i915/gt/intel_workarounds.c | 28 ++- drivers/gpu/drm/i915/gt/uc/intel_guc.c | 6 +- drivers/gpu/drm/i915/gvt/handlers.c | 8 +- drivers/gpu/drm/i915/gvt/reg.h | 4 +- drivers/gpu/drm/i915/i915_reg.h | 4 +- drivers/gpu/drm/i915/intel_uncore.c | 203 +++++++++++++------- drivers/gpu/drm/i915/intel_uncore.h | 4 +- 7 files changed, 171 insertions(+), 86 deletions(-) -- 2.24.1 _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx