Hi Chris, > For many configuration details within RC6 and RPS we are programming > intervals for the internal clocks. From gen11, these clocks are > configuration via the RPM_CONFIG and so for convenience, we would like > to convert to/from more natural units (ns). > > Signed-off-by: Chris Wilson <chris@xxxxxxxxxxxxxxxxxx> > Cc: Andi Shyti <andi.shyti@xxxxxxxxx> > Cc: Mika Kuoppala <mika.kuoppala@xxxxxxxxxxxxxxx> > --- > drivers/gpu/drm/i915/Makefile | 1 + > drivers/gpu/drm/i915/gt/debugfs_gt_pm.c | 27 +++++---- > drivers/gpu/drm/i915/gt/intel_gt_clk.c | 76 +++++++++++++++++++++++++ > drivers/gpu/drm/i915/gt/intel_gt_clk.h | 21 +++++++ > drivers/gpu/drm/i915/gt/intel_rps.c | 37 +++++++----- > drivers/gpu/drm/i915/gt/selftest_rps.c | 6 +- > drivers/gpu/drm/i915/i915_debugfs.c | 34 +++++++---- > drivers/gpu/drm/i915/i915_reg.h | 25 -------- > 8 files changed, 161 insertions(+), 66 deletions(-) > create mode 100644 drivers/gpu/drm/i915/gt/intel_gt_clk.c > create mode 100644 drivers/gpu/drm/i915/gt/intel_gt_clk.h I like the patch, it's a nice refactoring but the file name is misleading. When I see a *clk.[ch] file I think of a clock device rather than a set of utilities for frequency and interval conversion. Can we call the file intel_gt_timing.[ch] or clk_utils.[ch]? Andi _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx