On Fri, Mar 06, 2020 at 08:48:42PM +0530, Sharma, Swati2 wrote: > > > On 03-Mar-20 11:03 PM, Ville Syrjala wrote: > > From: Ville Syrjälä <ville.syrjala@xxxxxxxxxxxxxxx> > > > > chv_read_cgm_lut() specifically reads the CGM _gamma_ LUT so > > let's rename it to reflect that fact. This also mirrors > > the other direction's chv_load_cgm_gamma(). > > At present, since all the readouts are only gamma luts so should we > rename all the readouts like chv_read_gamma_lut()? No, the names are chosen based on the HW LUT we read not the SW LUT. > > > > > Signed-off-by: Ville Syrjälä <ville.syrjala@xxxxxxxxxxxxxxx> > > --- > > drivers/gpu/drm/i915/display/intel_color.c | 4 ++-- > > 1 file changed, 2 insertions(+), 2 deletions(-) > > > > diff --git a/drivers/gpu/drm/i915/display/intel_color.c b/drivers/gpu/drm/i915/display/intel_color.c > > index f90f113355bc..ab23b24e7be3 100644 > > --- a/drivers/gpu/drm/i915/display/intel_color.c > > +++ b/drivers/gpu/drm/i915/display/intel_color.c > > @@ -1780,7 +1780,7 @@ static void i965_read_luts(struct intel_crtc_state *crtc_state) > > } > > > > static struct drm_property_blob * > > -chv_read_cgm_lut(const struct intel_crtc_state *crtc_state) > > +chv_read_cgm_gamma(const struct intel_crtc_state *crtc_state) > > { > > struct intel_crtc *crtc = to_intel_crtc(crtc_state->uapi.crtc); > > struct drm_i915_private *dev_priv = to_i915(crtc->base.dev); > > @@ -1816,7 +1816,7 @@ chv_read_cgm_lut(const struct intel_crtc_state *crtc_state) > > static void chv_read_luts(struct intel_crtc_state *crtc_state) > > { > > if (crtc_state->cgm_mode & CGM_PIPE_MODE_GAMMA) > > - crtc_state->hw.gamma_lut = chv_read_cgm_lut(crtc_state); > > + crtc_state->hw.gamma_lut = chv_read_cgm_gamma(crtc_state); > > else > > i965_read_luts(crtc_state); > > } > > > > -- > ~Swati Sharma -- Ville Syrjälä Intel _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx