Re: [PATCH 4/5] drm/i915/gt: Rename lrc.c to execlists_submission.c

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 





On 1/28/20 12:43 PM, Chris Wilson wrote:
We want to separate the utility functions for controlling the logical
ring context from the execlists submission mechanism (which is an
overgrown scheduler).

This is similar to Daniele's work to split up the files, but being
selfish I wanted to base it after my own changes to intel_lrc.c petered
out.


Considering patch 5 as well, IMO we need gt/intel_execlists_submission.h as well, with the aim of not including that from any of the GuC files once we're done with adding the GuC version of the functions I think it'd be easier to rename lrc.h to execlists_submission.h in this patch (grep says it's only included in 3 places), then split it in the next patch and use the appropriate one when you move the include from drv.h to the specific files.

Daniele

Signed-off-by: Chris Wilson <chris@xxxxxxxxxxxxxxxxxx>
Cc: Daniele Ceraolo Spurio <daniele.ceraolospurio@xxxxxxxxx>
Cc: Tvrtko Ursulin <tvrtko.ursulin@xxxxxxxxx>
---
  drivers/gpu/drm/i915/Makefile                                   | 2 +-
  .../drm/i915/gt/{intel_lrc.c => intel_execlists_submission.c}   | 2 +-
  .../gpu/drm/i915/gt/{selftest_lrc.c => selftest_execlists.c}    | 0
  3 files changed, 2 insertions(+), 2 deletions(-)
  rename drivers/gpu/drm/i915/gt/{intel_lrc.c => intel_execlists_submission.c} (99%)
  rename drivers/gpu/drm/i915/gt/{selftest_lrc.c => selftest_execlists.c} (100%)

diff --git a/drivers/gpu/drm/i915/Makefile b/drivers/gpu/drm/i915/Makefile
index 3c88d7d8c764..58b0e86c71f7 100644
--- a/drivers/gpu/drm/i915/Makefile
+++ b/drivers/gpu/drm/i915/Makefile
@@ -86,6 +86,7 @@ gt-y += \
  	gt/intel_engine_pm.o \
  	gt/intel_engine_pool.o \
  	gt/intel_engine_user.o \
+	gt/intel_execlists_submission.o \
  	gt/intel_ggtt.o \
  	gt/intel_gt.o \
  	gt/intel_gt_irq.o \
@@ -94,7 +95,6 @@ gt-y += \
  	gt/intel_gt_requests.o \
  	gt/intel_gtt.o \
  	gt/intel_llc.o \
-	gt/intel_lrc.o \
  	gt/intel_mocs.o \
  	gt/intel_ppgtt.o \
  	gt/intel_rc6.o \
diff --git a/drivers/gpu/drm/i915/gt/intel_lrc.c b/drivers/gpu/drm/i915/gt/intel_execlists_submission.c
similarity index 99%
rename from drivers/gpu/drm/i915/gt/intel_lrc.c
rename to drivers/gpu/drm/i915/gt/intel_execlists_submission.c
index 5b14f5bae68a..aa67561fee53 100644
--- a/drivers/gpu/drm/i915/gt/intel_lrc.c
+++ b/drivers/gpu/drm/i915/gt/intel_execlists_submission.c
@@ -5290,5 +5290,5 @@ intel_engine_in_execlists_submission_mode(const struct intel_engine_cs *engine)
  }
#if IS_ENABLED(CONFIG_DRM_I915_SELFTEST)
-#include "selftest_lrc.c"
+#include "selftest_execlists.c"
  #endif
diff --git a/drivers/gpu/drm/i915/gt/selftest_lrc.c b/drivers/gpu/drm/i915/gt/selftest_execlists.c
similarity index 100%
rename from drivers/gpu/drm/i915/gt/selftest_lrc.c
rename to drivers/gpu/drm/i915/gt/selftest_execlists.c

_______________________________________________
Intel-gfx mailing list
Intel-gfx@xxxxxxxxxxxxxxxxxxxxx
https://lists.freedesktop.org/mailman/listinfo/intel-gfx



[Index of Archives]     [AMD Graphics]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux