Re: [PATCH 1/8] drm/i915/firmware: Load v2.0.0 HuC for SKL

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Since you're changing the firmwares for all platforms, I believe this would be a good occasion to have the HuC blobs follow the same naming convention as the guc ones for consistency, i.e:

	<platform>_<g/h>uc_<major>.<minor>.<patch>.bin

A single patch to update the MAKE_HUC_FW_PATH macro and all the blob defs would be required for that.

Daniele

On 9/5/19 11:39 AM, Anusha Srivatsa wrote:
Add support to load the latest version of HuC on SKL.

Cc: Daniele Ceraolo Spurio <daniele.ceraolospurio@xxxxxxxxx>
Signed-off-by: Anusha Srivatsa <anusha.srivatsa@xxxxxxxxx>
---
  drivers/gpu/drm/i915/gt/uc/intel_uc_fw.c | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/gpu/drm/i915/gt/uc/intel_uc_fw.c b/drivers/gpu/drm/i915/gt/uc/intel_uc_fw.c
index 296a82603be0..27482e4d7b06 100644
--- a/drivers/gpu/drm/i915/gt/uc/intel_uc_fw.c
+++ b/drivers/gpu/drm/i915/gt/uc/intel_uc_fw.c
@@ -45,7 +45,7 @@ void intel_uc_fw_change_status(struct intel_uc_fw *uc_fw,
  	fw_def(GEMINILAKE,  0, guc_def(glk, 33, 0, 0), huc_def(glk, 03, 01, 2893)) \
  	fw_def(KABYLAKE,    0, guc_def(kbl, 33, 0, 0), huc_def(kbl, 02, 00, 1810)) \
  	fw_def(BROXTON,     0, guc_def(bxt, 33, 0, 0), huc_def(bxt, 01,  8, 2893)) \
-	fw_def(SKYLAKE,     0, guc_def(skl, 33, 0, 0), huc_def(skl, 01, 07, 1398))
+	fw_def(SKYLAKE,     0, guc_def(skl, 33, 0, 0), huc_def(skl,  2,  0,    0))
#define __MAKE_UC_FW_PATH(prefix_, name_, separator_, major_, minor_, patch_) \
  	"i915/" \

_______________________________________________
Intel-gfx mailing list
Intel-gfx@xxxxxxxxxxxxxxxxxxxxx
https://lists.freedesktop.org/mailman/listinfo/intel-gfx




[Index of Archives]     [AMD Graphics]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux