Quoting Daniel Vetter (2019-08-15 08:23:01) > On Wed, Aug 14, 2019 at 07:57:57PM +0100, Chris Wilson wrote: > > Quoting Daniel Vetter (2019-08-14 19:49:41) > > > diff --git a/drivers/gpu/drm/i915/gem/i915_gem_object_types.h b/drivers/gpu/drm/i915/gem/i915_gem_object_types.h > > > index d474c6ac4100..1ea3c3c96a5a 100644 > > > --- a/drivers/gpu/drm/i915/gem/i915_gem_object_types.h > > > +++ b/drivers/gpu/drm/i915/gem/i915_gem_object_types.h > > > @@ -157,7 +157,15 @@ struct drm_i915_gem_object { > > > unsigned int pin_global; > > > > > > struct { > > > - struct mutex lock; /* protects the pages and their use */ > > > + /* > > > + * Protects the pages and their use. > > > > "Their use" is still a misleading suggest of mine. This should be > > "protects the pinning of pages". The couple of other things it is used > > for are tied to the concept of the pages being pinned; further use should > > be discouraged; direct use prohibited. > > So something like "Protects the pinning of pages. Do not use directly, but > instead go through the get/put_pages and pin/unpin interfaces." There's a > few too many of those to list them all imo ... I would say only pin/unpin. get/put is the for implementation. Fwiw, elsewhere we adopted the name pin_mutex / pin_count. But there's also variations on that naming scheme. The pattern of "that who is being pinned may unpin others" is repeating. -Chris _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx