Re: [PATCH v2 1/4] drm/i915/uc: Rename intel_uc_is_using* into intel_uc_supports*

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Quoting Michal Wajdeczko (2019-07-31 15:38:53)
> @@ -365,12 +365,12 @@ void intel_uc_fini(struct intel_uc *uc)
>  {
>         struct intel_guc *guc = &uc->guc;
>  
> -       if (!intel_uc_is_using_guc(uc))
> +       if (!intel_uc_supports_guc(uc))
>                 return;

Note by this point we should know whether or not we loaded the guc and
need to cleanup. So here is_using_guc() does read better. If we even
need to bother and just leave it to the huc_fini / guc_fini to be no-ops
when there is nothing to do.
-Chris
_______________________________________________
Intel-gfx mailing list
Intel-gfx@xxxxxxxxxxxxxxxxxxxxx
https://lists.freedesktop.org/mailman/listinfo/intel-gfx




[Index of Archives]     [AMD Graphics]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux