Quoting Jani Nikula (2019-05-22 15:50:27) > Move i915_reg_read_ioctl() declaration to intel_uncore.h, corresponding > to the definition in intel_uncore.c, and rename to > intel_uncore_reg_read_ioctl(). No functional changes. > > Signed-off-by: Jani Nikula <jani.nikula@xxxxxxxxx> > --- > diff --git a/drivers/gpu/drm/i915/intel_uncore.c b/drivers/gpu/drm/i915/intel_uncore.c > index f786681..36c37d 100644 > --- a/drivers/gpu/drm/i915/intel_uncore.c > +++ b/drivers/gpu/drm/i915/intel_uncore.c > @@ -1669,8 +1669,8 @@ static const struct reg_whitelist { > .size = 8 > } }; > > -int i915_reg_read_ioctl(struct drm_device *dev, > - void *data, struct drm_file *file) > +int intel_uncore_reg_read_ioctl(struct drm_device *dev, > + void *data, struct drm_file *file) Hmm. This doesn't fit into intel_uncore.c anyway. I liked the i915_ here as indication that this part of the uAPI and not a real function. It should be put into its nice little bubblewrapped container. i915_misc_uapi.c? i915_uapi_dungeon.c? -Chris _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx