On 29/01/2019 10:24, Chris Wilson wrote:
Quoting Tvrtko Ursulin (2019-01-29 10:14:45)
On 29/01/2019 08:58, Chris Wilson wrote:
diff --git a/drivers/gpu/drm/i915/intel_ringbuffer.h b/drivers/gpu/drm/i915/intel_ringbuffer.h
index 2927b712b973..5e2231d0c2fa 100644
--- a/drivers/gpu/drm/i915/intel_ringbuffer.h
+++ b/drivers/gpu/drm/i915/intel_ringbuffer.h
@@ -293,14 +293,18 @@ struct intel_engine_execlists {
unsigned int port_mask;
/**
- * @queue_priority: Highest pending priority.
+ * @preempt_priority_hint: Highest pending priority.
Would queue_priority_hint be better since it is used not just for
preemption but to start an idle GPU?
~o~
It's 2 letters shorter so that's a plus.
And it doesn't always relate to preemption per se. If you are happy with
adding _hint, then queue_priority_hint it shall be.
Yes I am, I know it is a rebasing hassle, but hint seems a worthy suffix
and preemption would be less accurate.
Regards,
Tvrtko
_______________________________________________
Intel-gfx mailing list
Intel-gfx@xxxxxxxxxxxxxxxxxxxxx
https://lists.freedesktop.org/mailman/listinfo/intel-gfx