== Series Details == Series: drm/i915: Clean up power well descriptors URL : https://patchwork.freedesktop.org/series/46952/ State : warning == Summary == $ dim checkpatch origin/drm-tip b6af654513ed drm/i915/icl: Fix power well anonymous union initializers -:7: WARNING:COMMIT_LOG_LONG_LINE: Possible unwrapped commit description (prefer a maximum 75 chars per line) #7: 0a445945be6d ("drm/i915: Work around GCC anonymous union initialization bug") -:7: ERROR:GIT_COMMIT_ID: Please use git commit description style 'commit <12+ chars of sha1> ("<title line>")' - ie: 'commit 0a445945be6d ("drm/i915: Work around GCC anonymous union initialization bug")' #7: 0a445945be6d ("drm/i915: Work around GCC anonymous union initialization bug") total: 1 errors, 1 warnings, 0 checks, 46 lines checked bf50420415cd drm/i915: Rename intel_power_domains_fini() to intel_power_domains_fini_hw() -:51: WARNING:FUNCTION_ARGUMENTS: function definition argument 'struct drm_i915_private *' should also have an identifier name #51: FILE: drivers/gpu/drm/i915/intel_drv.h:1946: +void intel_power_domains_fini_hw(struct drm_i915_private *); total: 0 errors, 1 warnings, 0 checks, 106 lines checked 2c558a680c71 drm/i915/vlv: Remove redundant power well ID asserts 796c168ad9bd drm/i915: Constify power well descriptors -:128: WARNING:FUNCTION_ARGUMENTS: function definition argument 'struct drm_i915_private *' should also have an identifier name #128: FILE: drivers/gpu/drm/i915/intel_drv.h:1945: +void intel_power_domains_cleanup(struct drm_i915_private *); -:558: CHECK:MACRO_ARG_REUSE: Macro argument reuse '__power_well_descs' - possible side-effects? #558: FILE: drivers/gpu/drm/i915/intel_runtime_pm.c:2846: +#define set_power_wells(power_domains, __power_well_descs) \ + __set_power_wells(power_domains, __power_well_descs, \ + ARRAY_SIZE(__power_well_descs)) total: 0 errors, 1 warnings, 1 checks, 638 lines checked c543fa2a1967 drm/i915/vlv: Use power well CTL IDX instead of ID ac38cdf6811d drm/i915/ddi: Use power well CTL IDX instead of ID -:264: ERROR:COMPLEX_MACRO: Macros with complex values should be enclosed in parentheses #264: FILE: drivers/gpu/drm/i915/i915_reg.h:8951: +#define CNL_AUX_ANAOVRD1(pw_idx) _MMIO(_PICK(_CNL_AUX_REG_IDX(pw_idx), \ _CNL_AUX_ANAOVRD1_B, \ _CNL_AUX_ANAOVRD1_C, \ _CNL_AUX_ANAOVRD1_D, \ total: 1 errors, 0 warnings, 0 checks, 969 lines checked 13de85c0b4d4 drm/i915: Remove redundant power well IDs fd4125220ab9 drm/i915: Make power well ID names more uniform 01e5d715c988 drm/i915: Use existing power well IDs where possible 0da627a1550f drm/i915/icl: Add missing power gate enums _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx