> -----Original Message----- > From: Nikula, Jani > Sent: Friday, June 29, 2018 2:58 PM > To: intel-gfx@xxxxxxxxxxxxxxxxxxxxx > Cc: Nikula, Jani <jani.nikula@xxxxxxxxx>; Chauhan, Madhav > <madhav.chauhan@xxxxxxxxx> > Subject: [RFC PATCH 1/2] drm/i915/dsi: rename the current DSI legacy > > Starting from ICL we have a new DSI block which requires completely > different programming from the current implementation. Having them in the > same file would be confusing. Rename the current DSI out of the way as > legacy DSI, to make way for the ICL+ implementation. We'll want to call the > new DSI block "intel_dsi". We can also use intel_dsi_byt.c, intel_dsi_byt_pll.c, intel_dsi_byt_init(), looks more informative and aligns with file naming convention inside i915/ as well. But having byt_dsi.c and so on looks different from naming perspective :) I am also fine with naming proposed by you i.e. using "legacy" for current Implementation, a legacy way :) Regards, Madhav > > References: https://patchwork.freedesktop.org/series/44823/ > Cc: Madhav Chauhan <madhav.chauhan@xxxxxxxxx> > Signed-off-by: Jani Nikula <jani.nikula@xxxxxxxxx> > > --- > > Are there any reasonable alternatives to "legacy"? > > Where we have the encoder implementations for different platforms in the > same file, the names would be platform derived. In the DSI case, we could > call this "BYT DSI" after the first platform with DSI support in i915, and name > the files and functions accordingly. byt_dsi.c, byt_dsi_pll.c, byt_dsi_init(), and > so on. > --- > drivers/gpu/drm/i915/Makefile | 4 ++-- > drivers/gpu/drm/i915/intel_drv.h | 2 +- > drivers/gpu/drm/i915/intel_dsi.h | 4 ++-- > drivers/gpu/drm/i915/{intel_dsi.c => intel_legacy_dsi.c} | 0 > drivers/gpu/drm/i915/{intel_dsi_pll.c => intel_legacy_dsi_pll.c} | 0 > 5 files changed, 5 insertions(+), 5 deletions(-) rename > drivers/gpu/drm/i915/{intel_dsi.c => intel_legacy_dsi.c} (100%) rename > drivers/gpu/drm/i915/{intel_dsi_pll.c => intel_legacy_dsi_pll.c} (100%) > > diff --git a/drivers/gpu/drm/i915/Makefile b/drivers/gpu/drm/i915/Makefile > index 4c6adae23e18..4bc6509efd28 100644 > --- a/drivers/gpu/drm/i915/Makefile > +++ b/drivers/gpu/drm/i915/Makefile > @@ -141,13 +141,13 @@ i915-y += dvo_ch7017.o \ > intel_dp_link_training.o \ > intel_dp_mst.o \ > intel_dp.o \ > - intel_dsi.o \ > intel_dsi_dcs_backlight.o \ > - intel_dsi_pll.o \ > intel_dsi_vbt.o \ > intel_dvo.o \ > intel_hdmi.o \ > intel_i2c.o \ > + intel_legacy_dsi.o \ > + intel_legacy_dsi_pll.o \ > intel_lspcon.o \ > intel_lvds.o \ > intel_panel.o \ > diff --git a/drivers/gpu/drm/i915/intel_drv.h > b/drivers/gpu/drm/i915/intel_drv.h > index a6ff2600a3a0..65e1b4ddc0d0 100644 > --- a/drivers/gpu/drm/i915/intel_drv.h > +++ b/drivers/gpu/drm/i915/intel_drv.h > @@ -1730,7 +1730,7 @@ int intel_dp_aux_init_backlight_funcs(struct > intel_connector *intel_connector); > /* intel_dp_mst.c */ > int intel_dp_mst_encoder_init(struct intel_digital_port *intel_dig_port, int > conn_id); void intel_dp_mst_encoder_cleanup(struct intel_digital_port > *intel_dig_port); > -/* intel_dsi.c */ > +/* intel_legacy_dsi.c */ > void intel_dsi_init(struct drm_i915_private *dev_priv); > > /* intel_dsi_dcs_backlight.c */ > diff --git a/drivers/gpu/drm/i915/intel_dsi.h > b/drivers/gpu/drm/i915/intel_dsi.h > index 7afeb9580f41..429471ca49ca 100644 > --- a/drivers/gpu/drm/i915/intel_dsi.h > +++ b/drivers/gpu/drm/i915/intel_dsi.h > @@ -129,11 +129,11 @@ static inline struct intel_dsi > *enc_to_intel_dsi(struct drm_encoder *encoder) > return container_of(encoder, struct intel_dsi, base.base); } > > -/* intel_dsi.c */ > +/* intel_legacy_dsi.c */ > void wait_for_dsi_fifo_empty(struct intel_dsi *intel_dsi, enum port port); > enum mipi_dsi_pixel_format pixel_format_from_register_bits(u32 fmt); > > -/* intel_dsi_pll.c */ > +/* intel_legacy_dsi_pll.c */ > bool intel_dsi_pll_is_enabled(struct drm_i915_private *dev_priv); int > intel_compute_dsi_pll(struct intel_encoder *encoder, > struct intel_crtc_state *config); > diff --git a/drivers/gpu/drm/i915/intel_dsi.c > b/drivers/gpu/drm/i915/intel_legacy_dsi.c > similarity index 100% > rename from drivers/gpu/drm/i915/intel_dsi.c rename to > drivers/gpu/drm/i915/intel_legacy_dsi.c > diff --git a/drivers/gpu/drm/i915/intel_dsi_pll.c > b/drivers/gpu/drm/i915/intel_legacy_dsi_pll.c > similarity index 100% > rename from drivers/gpu/drm/i915/intel_dsi_pll.c > rename to drivers/gpu/drm/i915/intel_legacy_dsi_pll.c > -- > 2.11.0 _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx