On 11/15/2017 1:01 AM, Chris Wilson wrote:
Quoting Michal Wajdeczko (2017-11-14 19:23:24)
On Tue, 14 Nov 2017 19:27:26 +0100, Chris Wilson
<chris@xxxxxxxxxxxxxxxxxx> wrote:
Quoting Sagar Arun Kamble (2017-11-14 18:19:01)
On 11/14/2017 5:53 PM, Michal Wajdeczko wrote:
On Mon, 13 Nov 2017 09:48:11 +0100, Sagar Arun Kamble
<sagar.a.kamble@xxxxxxxxx> wrote:
-static void i915_guc_irq_handler(unsigned long data)
+static void intel_guc_irq_handler(unsigned long data)
and verbose "guc_submission_handler()" ?
Yes. Should we rename irq_tasklet to submission_tasklet?
then we can s/intel_lrc_irq_handler/execlists_submission_tasklet and
s/i915_guc_irq_handler/guc_submission_tasklet.
Again trying to maintain the nomenclature consistency for Execlists and
GuC.
Ok. Do that as a separate (initial) step.
Hmm. By "tasklet" I usually think of "tasklet_struct". Then
"guc_submission_tasklet" suggests that this is another kind
or customized "tasklet" struct. So maybe use full name:
s/i915_guc_irq_handler/guc_submission_tasklet_func ?
Please no. You'll grow to dislike the tautology immensely!
struct tasklet tasklet;
execlists->tasklet = execlists_submission_tasklet;
You meant "execlists->tasklet.func =" here right?
execlists->tasklet = guc_submission_tasklet;
tasklet_schedule(engine->execlists.tasklet) etc
is clear to me.
-Chris
Michal wanted to distinguish tasklet func from tasklet.
I thought of naming vfunc as submission_tasklet and component functions
as execlists/guc_submission_tasklet_func (with michal suggestion).
But that is looking little big i guess.
With Michal's initial suggestion how about below change? (irq_tasklet
was little misleading for me)
struct tasklet tasklet;
execlists->tasklet.func = execlists_submission_handler;
execlists->tasklet.func = guc_submission_handler;
tasklet_schedule(engine->execlists.tasklet)
_______________________________________________
Intel-gfx mailing list
Intel-gfx@xxxxxxxxxxxxxxxxxxxxx
https://lists.freedesktop.org/mailman/listinfo/intel-gfx