We want to have consistent function/structure/file naming and function parameter semantics. Suggestion from Michal Wajdeczko about using "genx_" prefix (or better _genx" suffix for all hw related structures types, offsets), "i915_" prefix for driver entry calls and "intel_" in all other seems to be the good scheme to go ahead. Also we need to adhere to practise of passing drm_i915_private to functions with "i915_" prefix and component structure to functions with "intel_" prefix. This series updates GuC submission related code with these changes. With GuC submission being hardware interface for i915, we should name those functions with prefix "intel_guc" and pass struct intel_guc as parameter. Also i915_guc_client struct is kernel-hw interaction structure hence rename that to intel_guc_client. With these changes GuC submission source files are now named with "intel_" prefix. Please add to Cc as I might not have covered all interested in this change. Cc: Michal Wajdeczko <michal.wajdeczko@xxxxxxxxx> Cc: Michal Winiarski <michal.winiarski@xxxxxxxxx> Cc: Oscar Mateo <oscar.mateo@xxxxxxxxx> Cc: Daniele Ceraolo Spurio <daniele.ceraolospurio@xxxxxxxxx> Cc: Arkadiusz Hiler <arkadiusz.hiler@xxxxxxxxx> Cc: Chris Wilson <chris@xxxxxxxxxxxxxxxxxx> Cc: Tvrtko Ursulin <tvrtko.ursulin@xxxxxxxxx> Cc: Joonas Lahtinen <joonas.lahtinen@xxxxxxxxxxxxxxx> (Ignore checkpatch errors in patch 2&3 as they are not introduced by this series) Sagar Arun Kamble (3): drm/i915/guc: Update name and prototype of GuC submission related functions drm/i915/guc: Rename i915_guc_client struct to intel_guc_client drm/i915/guc: Rename i915_guc_submission.c|h to intel_guc_submission.c|h drivers/gpu/drm/i915/Makefile | 4 +- drivers/gpu/drm/i915/i915_debugfs.c | 6 +- drivers/gpu/drm/i915/i915_guc_submission.c | 1466 --------------------------- drivers/gpu/drm/i915/i915_guc_submission.h | 80 -- drivers/gpu/drm/i915/intel_guc.c | 2 +- drivers/gpu/drm/i915/intel_guc.h | 6 +- drivers/gpu/drm/i915/intel_guc_submission.c | 1463 ++++++++++++++++++++++++++ drivers/gpu/drm/i915/intel_guc_submission.h | 80 ++ drivers/gpu/drm/i915/intel_uc.c | 12 +- 9 files changed, 1558 insertions(+), 1561 deletions(-) delete mode 100644 drivers/gpu/drm/i915/i915_guc_submission.c delete mode 100644 drivers/gpu/drm/i915/i915_guc_submission.h create mode 100644 drivers/gpu/drm/i915/intel_guc_submission.c create mode 100644 drivers/gpu/drm/i915/intel_guc_submission.h -- 1.9.1 _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx